Untrusted domain not updated on config.php

php
10

#1

hi all,
I have problems with "untrusted domain’ in spite of modifying the config.php file as follows:
‘trusted_domains’ => [
0 => ‘https://www.xxxxxxxxx.es/owncloud’,
],

I have made a copy of the owncloud directory from my web server to a new location in order to take advantage of having a https addess

However, when I copied (cp -r xxxxx) the directory to the new location and updated the config.php file (see above) I got the unstrusted domain error message in spite of trying the access owncloud from the https address.

It seems like owncloud is not reading properly config.php. I checked the privileges: and it seems right: -rw-r----- (I also tried -rw-r–r--).

I also tried in the trusted domains other options, such as xxxxx.es/owncloud

Any ideas on what could be wrong with my new installation?. Thank you very much in advance for your support


#2

I don’t understand, why you should move your installation, just for switching to https. If this is really required, why don’t you reinstall at the final location? Should be no problem ans solves all you current issues. Obviously ownCloud doesn’t like such movements, what I fully understand.


#3

Hey,

i don’t think that your trusted_domains setting is correct:

https is a protocol, /owncloud a folder on your server and both are not part of a “domain”. Maybe it helps you to understand what to put into the trusted_domains stetting if you have at the ownCloud documentation on this topic available here:

https://doc.owncloud.org/server/latest/admin_manual/installation/source_installation.html?highlight=trusted#managing-trusted-domains


#4

Thanks Tom, you were right, by removing the folder in the trusted_domains seems to work.

‘trusted_domains’ =>
array (
0 => ‘www.xxxxxxx.es’,
),

I read the documentation before writing the post but I did not realised that the important issue was the domain address (without any folders).

Thank you very much Tom42 and alfredb for your support.