Update 10.0.3.3 to 10.0.6 stuck

upgrade
10

#1

Hello, I tried an update from 10.0.3 to 10.0.6 on a debian server, softaclous installation, via the UI updater.

For 3/4 hrs it's stuck now, no changes in the files visible, these are some log entries:

{"reqId":"Wnf2YH8AAQEAAF3KluAAAAAD","level":3,"time":"2018-02-05T06:14:56+00:00","remoteAddr":"123.123.123.123","user":"--","app":"PHP","method":"POST","url":"\/index.php\/occ\/app:list","message":"Invalid argument supplied for foreach() at \/var\/www\/vhosts\/myserver.de\/owncloud.myserver.de\/lib\/composer\/symfony\/console\/Input\/ArgvInput.php#268"}
{"reqId":"Wnf2YH8AAQEAAF3KluAAAAAD","level":3,"time":"2018-02-05T06:14:56+00:00","remoteAddr":"123.123.123.123","user":"--","app":"PHP","method":"POST","url":"\/index.php\/occ\/app:list","message":"Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php:\/\/input stream instead. at Unknown#0"}
{"reqId":"Wnf2YH8AAQEAAB8qkIgAAAAG","level":3,"time":"2018-02-05T06:14:56+00:00","remoteAddr":"123.123.123.123","user":"--","app":"PHP","method":"POST","url":"\/index.php\/occ\/app:getpath","message":"Undefined index: argv at \/var\/www\/vhosts\/myserver.de\/owncloud.myserver.de\/lib\/composer\/symfony\/console\/Input\/ArgvInput.php#55"}
{"reqId":"Wnf2YH8AAQEAAB8qkIgAAAAG","level":3,"time":"2018-02-05T06:14:56+00:00","remoteAddr":"123.123.123.123","user":"--","app":"PHP","method":"POST","url":"\/index.php\/occ\/app:getpath","message":"array_shift() expects parameter 1 to be array, null given at \/var\/www\/vhosts\/myserver.de\/owncloud.myserver.de\/lib\/composer\/symfony\/console\/Input\/ArgvInput.php#59"}
{"reqId":"Wnf2YH8AAQEAAB8qkIgAAAAG","level":3,"time":"2018-02-05T06:14:56+00:00","remoteAddr":"123.123.123.123","user":"--","app":"PHP","method":"POST","url":"\/index.php\/occ\/app:getpath","message":"Invalid argument supplied for foreach() at \/var\/www\/vhosts\/myserver.de\/owncloud.myserver.de\/lib\/composer\/symfony\/console\/Input\/ArgvInput.php#268"}
{"reqId":"Wnf2YH8AAQEAAB8qkIgAAAAG","level":3,"time":"2018-02-05T06:14:56+00:00","remoteAddr":"123.123.123.123","user":"--","app":"PHP","method":"POST","url":"\/index.php\/occ\/app:getpath","message":"Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php:\/\/input stream instead. at Unknown#0"}
{"reqId":"Wnf2YH8AAQEAAHfnTqAAAAAC","level":3,"time":"2018-02-05T06:14:56+00:00","remoteAddr":"123.123.123.123","user":"--","app":"PHP","method":"POST","url":"\/index.php\/occ\/app:getpath","message":"Undefined index: argv at \/var\/www\/vhosts\/myserver.de\/owncloud.myserver.de\/lib\/composer\/symfony\/console\/Input\/ArgvInput.php#55"}
{"reqId":"Wnf2YH8AAQEAAHfnTqAAAAAC","level":3,"time":"2018-02-05T06:14:56+00:00","remoteAddr":"123.123.123.123","user":"--","app":"PHP","method":"POST","url":"\/index.php\/occ\/app:getpath","message":"array_shift() expects parameter 1 to be array, null given at \/var\/www\/vhosts\/myserver.de\/owncloud.myserver.de\/lib\/composer\/symfony\/console\/Input\/ArgvInput.php#59"}
{"reqId":"Wnf2YH8AAQEAAHfnTqAAAAAC","level":3,"time":"2018-02-05T06:14:56+00:00","remoteAddr":"123.123.123.123","user":"--","app":"PHP","method":"POST","url":"\/index.php\/occ\/app:getpath","message":"Invalid argument supplied for foreach() at \/var\/www\/vhosts\/myserver.de\/owncloud.myserver.de\/lib\/composer\/symfony\/console\/Input\/ArgvInput.php#268"}
{"reqId":"Wnf2YH8AAQEAAHfnTqAAAAAC","level":3,"time":"2018-02-05T06:14:56+00:00","remoteAddr":"123.123.123.123","user":"--","app":"PHP","method":"POST","url":"\/index.php\/occ\/app:getpath","message":"Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php:\/\/input stream instead. at Unknown#0"}
{"reqId":"Wnf2eX8AAQEAABpZumAAAAAS","level":3,"time":"2018-02-05T06:15:57+00:00","remoteAddr":"123.123.123.123","user":"--","app":"PHP","method":"POST","url":"\/index.php\/occ\/upgrade","message":"str_repeat(): Second argument has to be greater than or equal to 0 at \/var\/www\/vhosts\/myserver.de\/owncloud.myserver.de\/lib\/composer\/symfony\/console\/Helper\/ProgressBar.php#517"}

What should I do?

Cheers,
Wolf


#2

Hi,

did your ownCloud work back on 10.0.3?

What is your config.php?


#3

Thanks for your reply. Yes, 10.0.3 worked in general, but it suffered from 423 - file locked - errors. That was the reason for the update.

Btw: these are the last entries from update.log:

[debug] Replacing public.php
[debug] Replacing remote.php
[debug] Replacing robots.txt
[debug] Replacing status.php
[debug] Replacing version.php

Chers,
Wolf


#4

You might find this interesting:

https://central.owncloud.org/t/423-locked-file-when-trying-to-update/11730/5


#5

Hm. I deleted the oc_file_locks table before, but the errors immediately came back. So it may not have been empty when starting the upgrade.
And AFAIK crons ran regularly.


#6

can you try to start cron manually?


#7

At the moment I cannot access the UI, it says it is in the maintainance mode. Could I do it via ssl?


#8

ssh, yes I would recommend you try it.


#9

I searched for it, but could not find a solution. Can you give me a hint?


#10

Have you ran the cronjob manually?


#11

Sorry, I'm not 100% certain about that.
In the UI, as far as I remember, cron was first set to "AJAX", and it said "last cron done one minute before".
I changed that setting to "system" as recommended. Next morning I came back and UI said "last cron done 5hrs ago". I think I did not do a manual cron - not 100% certain about that.


#12

I just tried - ssh access to my server (it's very limited anyway) does not provide the occ command. So I'm out of the game, true? - New installation required?


#13

do you have root access to the server?


#14

The su command is not available. So I think - no. True?


#15

Probably. If you can't connect to the server as root, or execute commands with root privileges, then you can't execute the occ commands.

I would recommend a clean install


#16

Well. I played back the backup. ):
Thank you for your help!


#17

No Problem, I am glad that you have a working system again :slight_smile: