Update by Commandline after Update

doc_answered
update
9.1.x
help

#1

Steps to reproduce
1. Realitze Manually upgrading
2. Activation of Apps
3. Error by activating LDAP
4. Forwarding to attached page

Expected behaviour
Nothing should happen and owncloud should be used normally.

Actual behaviour
It is not able to log in in owncloud. But there is a message that update is necessary and i should use the command line.
But i have no idea how. haven´t done it before. Never used a command line.
Hoster is "all-inkl.com"

Server configuration
Operating system:
Web server:
Database:
PHP version: 5.7
ownCloud version (see ownCloud admin page): 9.1.2
Updated from an older ownCloud or fresh install: From 9.1.1
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

ownCloud log (data/owncloud.log)

Need urgend help!! :frowning:


Update 9.0.6.5 zu 9.1.2 mittels Komandozeile
#2

Hi,

it helps to click on the "Dokumentation" link in the posted message which guides you to the documentation containing the needed steps how to do the update.


#3

But i have no idea were the commandline is?
I´m using all-inkl as hoster and there is no commandline.
I have no root access, if it would be necessary!
And in my agreement there is no SSh available.


#4

Hi,

unfortunately then you're probably lost as you need access via command line / SSH to the server to finish the update.


#5

Just remembered a dirty way, however you're doing this on your own risk and by risking a failed update.

Edit your lib/base.php file via FTP/whatever and change:

$tooBig = ($totalUsers > 50);

to

$tooBig = ($totalUsers > 500);

Source: https://github.com/owncloud/core/blob/v9.1.2/lib/base.php#L362

However you should do backups as they probably had a very good reason to add this check in there.

And you should really switch to a hoster / package which provides you command line access via SSH.


Update 9.0.6.5 zu 9.1.2 mittels Komandozeile
#6

Does this change the total nomber of users?
Because i´ve got only 6 users in OC.


#7

Hi,

this will only change the check for the max amount of users. If you have only 6 users please create an additional bugreport at https://github.com/owncloud/core/issues

This initial message about a too large instance should be only shown if you have more then 50 users.


#8

Dirty way does not help.
No reaction after changing "totaluUsers" to 500.

Now i need ssh help.
Don´t know what to to with the commands in the documentation.
I said it already, i have absolutely know knowledge with ssh.
Somebody who can help me, step by step?

I have changed my agreement for someone with ssh access, but it is not able to get root access. Do i need root access?
Ssh access by "fire ssh" for firefox and it was successfull. But i don´t know what to do now!


#9

Hi,

step by step instructions are available here:

https://doc.owncloud.org/server/latest/admin_manual/maintenance/manual_upgrade.html

Overall it might be enough if you just switch to your owncloud installation folder and run:

php occ upgrade

If that doesn't work you might need to do some research how to apply the instructions above to your environment. Most people in here probably don't know all-inkl so it will be hard to give specific guidance. Especially as it seems that you're not familiar with linux which is a requirement if your want to run software like ownCloud.


#10

Now i startet the upgrade, how you told me.
But following warning is shown.

PHP Warning: fopen(/www/htdocs/.../cloud/config/config.php): failed to open stream: Permission denied in /www/htdocs/.../cloud/lib/private/Config.php on line 187
Warning: fopen(/www/htdocs/.../cloud/config/config.php): failed to open stream: Permission denied in /www/htdocs/.../cloud/lib/private/Config.php on line 187
PHP Warning: flock() expects parameter 1 to be resource, boolean given in /www/htdocs/.../cloud/lib/private/Config.php on line 197
Warning: flock() expects parameter 1 to be resource, boolean given in /www/htdocs/.../cloud/lib/private/Config.php on line 197
An unhandled exception has been thrown:
exception 'Exception' with message 'Could not acquire a shared lock on the config file /www/htdocs/.../cloud/config/config.php' in /www/htdocs/.../cloud/lib/private/Config.php:198
Stack trace:
#0 /www/htdocs/.../cloud/lib/private/Config.php(58): OC\Config->readData()
#1 /www/htdocs/.../cloud/lib/base.php(129): OC\Config->__construct('/www/htdocs/w00...')
#2 /www/htdocs/.../cloud/lib/base.php(507): OC::initPaths()
#3 /www/htdocs/.../cloud/lib/base.php(973): OC::init()
#4 /www/htdocs/.../cloud/console.php(58): require_once('/www/htdocs/w00...')
#5 /www/htdocs/.../cloud/occ(11): require_once('/www/htdocs/w00...')


#11

Yes, thats because your ssh user is another user ownCloud is running as. You need to somehow get managed to run that command as the user which is running your webserver.


#12

Ah ok, but how?
I see, that "config.php" has ower "www-data". I think php ownder, or something like.
I can change the user, but if I´ve done this in the past oc was not able to run.
Should I change?


#13

So i Changed the owner to my access datas for folowing follders:
- apps
- config
- data

Then started the upgrade again.
Upgrade is done and oc seems to work!!!

THANK YOU VERY MUCH RealRancor!!!!!

So it is a issue for github?


#14

Hi,

glad you got this to work.

The updating issue itself not, but the issue that you're getting the message about the "large instance" for only 6 users is something a developer should have a look at.