Update from 10.0.4 to 10.0.5 fails


#1

Hello -

I run Ubuntu 16.04.3 with latest updates/upgrades installed
also with a recent php update to 1:7.2+59+ubuntu16.04.1+deb.sury.org.1)) - there is only one update that hangs in queue - php-mcrypt package
php-mcrypt/xenial,xenial 1:7.2+58+ubuntu16.04.1+deb.sury.org+1 all [aktualisierbar von: 1:7.1+55+ubuntu16.04.1+deb.sury.org+1]
php-mcrypt/now 1:7.1+55+ubuntu16.04.1+deb.sury.org+1 all [Installiert,aktualisierbar auf: 1:7.2+58+ubuntu16.04.1+deb.sury.org+1]
php-mcrypt/xenial,xenial 1:7.0+35ubuntu6 all
I am not sure whether this is relevant - as OC 10.0.4 ran ok over the past days

Today the updates came for MySQL and Owncloud via debian Package update(actually in multiple junks)
-->

Steps to reproduce - don't know - Have the latest 16.04 with all updates up to date, update to 10.0.5 via package manager

Expected behaviour

Tell us what should happen - I always expect clean updates with all dependencies checked by the update process

Actual behaviour

Tell us what happens instead
-OCC upgrade does not work (environment not properly prepared in var/www/owncloud/lib/private/Console/application.php:135) - nor any other occ command
- checked Status of OC via the Web Interface. It told me that an update to 10.5 was waiting, so I started the update via the Web Interface. All 28 items passed. Finally the integrity check was running - and concluded with error (no information on the Webpage) - now it says its in maintenance mode
As OCC commands don't work what can I do to my environment to get it working?

Server configuration

Operating system:
Ubuntu 16.04.1
Web server:
Apache2
Database:
MySQL
PHP version:
7.2
ownCloud version: (see ownCloud admin page)
10.0.5 (update not completed)
Updated from an older ownCloud or fresh install:
from 10.0.4
Where did you install ownCloud from:
repository download.owncloud.org/download/repositories/10.0/ubuntu16.04 release
apt get update and apt get upgrade
Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

does not work - webinterface in Maint mode

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder
-- Does not work - as the php environment is not properly prepared

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.
```-- Does not work - as the php environment is not properly prepared


**Are you using external storage, if yes which one:** local/smb/sftp/...
No

**Are you using encryption:** yes/no
No

**Are you using an external user-backend, if yes which one:** LDAP/ActiveDirectory/Webdav/...
No
#### LDAP configuration (delete this part if not used)

```
With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.
```

### Client configuration
**Browser:**
Firefoy
**Operating system:**

### Logs
#### Web server error log
```
Insert your webserver log here
```

#### ownCloud log (data/owncloud.log)
```
Insert your ownCloud log here
```

#### Browser log
```
Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

I fixed it myself - just removed php-mcrypt and installed all versions from 5.6 to 7.2 maually.
Now I can run occ again and did a occ Upgrade - it was mainly a repair. And rerun integrity check via the Web Interface.
OC 10.0.5 is running smoothly now.


#3

Good to hear you've fixed your problem!
Note that 10.0.5 has an important bug regarding translations that should be fixed in 10.0.6 (to be released soon). I'm not sure if it's reproducible in english though, so maybe you won't bump into it, but it's recommended to update a bit after it's available.