Update from 8.1 to 10.0.10.4 (CentOS 7) Data dir accessible over the internet


#1

Hi,

i am on an updated CentOS 7 and i migrated from owncloud 8.1 to 10.0.10.4.
Now for some reason the data dir is accessible from the internet.

I tried to add allowoverride all to my virtual host definition but it doesnt work.

I have a .htaccess in data directory with the following contents:

# Generated by ownCloud on 2019-02-16 23:55:13
# line below if for Apache 2.4
<ifModule mod_authz_core.c>
Require all denied
</ifModule>

# line below if for Apache 2.2
<ifModule !mod_authz_core.c>
deny from all
Satisfy All
</ifModule>

# section for Apache 2.2 and 2.4
<ifModule mod_autoindex.c>
IndexIgnore *
</ifModule>

I have no idea what to do, can someone help me please?

Regards Jens


#2

Which apache version are you running?
Are you sure htaccess support is enabled on your apache config?
Please note that we recommend to place the data directory outside of the owncloud folder.
Here is a tutorial on how to move the data directory: https://doc.owncloud.org/server/10.0/admin_manual/maintenance/manually-moving-data-folders.html


#3

Hi,

apache version is: httpd-2.4.6-88.el7.centos.x86_64
I am not sure htaccess is enabled, would you please tell howto do it?

I would also move the data dir outside the website, hopefully this approach is not too hard.

Regards Jens


#4

Hi,

i could solve the problem, i thought it’s enough to only set allow override all for the specific directory.
Since i set all to “All” it works and owncloud is telling me access forbidden.

Anyway, i like the idea to move the data dir out of the website dir. I will do this as next step.
Thank you for your help.

Regards Jens