Update from 9.1.4 to 10.7 -- first steps of guide do not match my system

Hello,

my system is at OC9.1.4, and I wanted to upgrade it to 10.7.

The table at doc.owncloud.com server admin_manual maintenance upgrade.html is telling this should be a straight thing, isn’t it?

The mentioned preferred manual upgrade as of doc.owncloud.com server admin_manual maintenance manual_upgrade.html is listing the steps to do so.

But already the very first one is failing, basically the specified user “www-data” doesn’t exist at all.

Next step would be to stop the web server, apache2 doesn’t seem to exist as a service?

Hm.

with more info I cannot do the post, removed, will try to attach it as a file. (PuTTY outputs).
(sorry new users can only place two URLs – no URLs included in my text – confused)

any suggestions appreciated, regards, Rudi.


[root@oc02 ~]# cat /etc/os-release
NAME=“CentOS Linux”
VERSION=“7 (Core)”
ID=“centos”
ID_LIKE=“rhel fedora”
VERSION_ID=“7”
PRETTY_NAME=“CentOS Linux 7 (Core)”
ANSI_COLOR=“0;31”
CPE_NAME=“cpe:/o:centos:centos:7”
HOME_URL=“https://www.centos.org/
BUG_REPORT_URL=“https://bugs.centos.org/

CENTOS_MANTISBT_PROJECT=“CentOS-7”
CENTOS_MANTISBT_PROJECT_VERSION=“7”
REDHAT_SUPPORT_PRODUCT=“centos”
REDHAT_SUPPORT_PRODUCT_VERSION=“7”

[root@oc02 ~]# uname -r
3.10.0-514.10.2.el7.x86_64

[root@oc02 ~]# awk -F: ‘{ print $1}’ /etc/passwd
root
bin
daemon
adm
lp
sync
shutdown
halt
mail
operator
games
ftp
nobody
avahi-autoipd
systemd-bus-proxy
systemd-network
dbus
polkitd
tss
postfix
sshd
seafile
mysql
apache
nginx
ntp
tcpdump

Web GUI login as admin, https:///settings/admin is telling at the bottom:

Version
ownCloud 9.1.4 (production)

the DB seems to be a MariaDB:

[root@oc02 bin]# mysql -u root -p
Enter password:
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 3131
Server version: 5.5.52-MariaDB MariaDB Server

Copyright © 2000, 2016, Oracle, MariaDB Corporation Ab and others.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

MariaDB [(none)]>
MariaDB [(none)]>
MariaDB [(none)]>
MariaDB [(none)]> show databases;
±-------------------+
| Database |
±-------------------+
| information_schema |
| mysql |
| owncloud_db |
| performance_schema |
±-------------------+
4 rows in set (0.01 sec)

sudo -u www-data php occ maintenance:mode --on
sudo: unknown user: www-data
sudo: Regelwerks-Plugin konnte nicht initialisiert werden
[root@oc02]# sudo bash
[root@oc02]# php occ maintenance:mode --on
Could not open input file: occ

[root@oc02]# php occ maintenance:mode --on
Could not open input file: occ
[root@oc02]# find / -name occ
/root/owncloud/occ
^C
[root@oc02]# cd /root/owncloud/
[root@oc02 owncloud]# php ./occ maintenance:mode --on
ownCloud is not installed - only a limited number of commands are available

[Symfony\Component\Console\Exception\CommandNotFoundException]
Command “maintenance:mode” is not defined.
Did you mean this?
maintenance:install

[root@oc02 owncloud]#

Hi rudi,

On centos the webserver user is apache, see https://doc.owncloud.com/server/admin_manual/configuration/server/occ_command.html#run-occ-as-your-http-user

So in all examples you must replace www-data with apache

# find / -name occ
/root/owncloud/occ
^C

If you had not stopped the find command it would have shown some other directory (I guess somewhere in /var/www).

You sure don’t have your ownCloud installation in the root directory. Refer to your apache configuration where your ownCloud directory is and try again :slight_smile:

HTH

thanks my issue has been fixed.