Update from OC 8.2 to OC 10.0.10 - Mismatch betweeen PHP and OC


#1

Hi All!
I am running Owncloud in the version 8.2.0.12 on a managed server. Since everything was working fine under php 5.6 I unfortunately didn´t pay attention to the updates in recent times. A few weeks ago the server got an php update and actually I can choose between the php versions 7.1 and 7.2. Those php versions doesnt work with Owncloud as it is currently installed. I tried to upgrade first to Owncloud 9.1.8. This wont work as php 7 is not supported. Therefore I tried a direct update to Owncloud 10 (which supports php 7) but I got the (expected) feddback that “Updates between multiple major versions and downgrades are unsupported”. I am not an expert with these issues and I would appreciate it very much if anybody more initimate with those problems could give me an easy to reproduce hint that might help me to adress and solve the problem.
Thx for your help, after two hours looking through the forums I am kind of desperated as there seems to be an - at least for me unresolvable - mismatch between php and OC versions.
Best regards
Prados

Steps to reproduce

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:

Web server:

Database:

PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

This should not show up if you are upgrading to oc10. Please make sure you really have oc10 source installed on your server.


#3

If I understood the version.php correctly, I can only upgrade to 10.0.10 from the versions 8.2.11 or 9.0.9 or 9.1
In my case the running version of owncloud is 8.2.0.12 and it says: “Updates between multiple major versions and downgrades are unsupported”. After reading your comment I checked it again, but the OC version used for the update is 10.0.10
Is it possible to set up a completely new installation of OC 10.0.10 in a different space and just importing the old database and maybe the old config and data files? I have a backup available and tried it already but it seems that the different old and new parts doesnt fit together. Sorry for the trouble but I am far away from being a professional database administrator :slight_smile:
Best regards Prados


#4

Hey,

from what i have read so far you would need to first update 8.2.0 to 8.2.11 before being able to upgrade directly to 10.0.10.


#5

Hi Tom, that is exactly my problem. The provider of my hosting space switched to php 7.2 recently and disabled the lower/older php versions. But my existing OC installation (and although the next update step to 8.2.11) does not work with php 7.2 and I only see a white screen. I currently don´t have a clue how to do the necessary updates step by step (I am completly aware that it is not possible to do it in just one major step) while only the new php version 7.2 can be used. Any idea?


#6

While waiting for a helpful hint I tried to set up a local xampp environment to make the updates with php 5.6 environment. Unfortunately the old xampp version with php 5.6 cant be installed on my windows 10 system. Don´t have no more ideas and would appreciate any further information that could lead me towards the right direction…


#7

Hey,

with such an old version which is stuck without the possibility to upgrade i would do the following steps:

  1. Save all files from the remote server locally
  2. Completely wipe the old installation and its database
  3. Setup a fresh ownCloud 10.0.10 installation
  4. Upload the saved files from 1. to the new installation

#8

Yet another reason why we should stop supporting such environments. Trouble all over the place …


#9

Thx for all your tipps and helpfull comments that came just in time. I followed Tom´s suggestion and started a fresh installation and just finished succesfully to migrate the old data manually. Lesson learned: always keep an eye on the updates to avoid getting stucked again even if it is sometimes hard to follow this guideline if you are not running those systems as a professional.


#10

Hey,

nice that you got this to work again. :+1:

But from what i have read in the past starting with ownCloud 10 it isn’t required anymore to step by step upgrade an old installation. So e.g. if you’re staying on 10.0 and there is an ownCloud 12.0 available in the future you could immediately go to 12.0.