Update in Dreamhost: cURL error 7: Failed to connect to localhost port 80: Connection refused


#1

Steps to reproduce

  1. Open de web updater.

Expected behaviour

No upgrade.

Actual behaviour

No upgrade and the log

cURL error 7: Failed to connect to localhost port 80: Connection refused

Server configuration

Database: MySQL

PHP version: 7.0

ownCloud version: 9.0.4 and 10.0.2.1

Signing status (ownCloud 9.0 and above):

9.0.4:

Technical information
=====================
The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results
=======
- core
	- INVALID_HASH
		- 3rdparty/guzzlehttp/guzzle/src/Client.php
		- 3rdparty/patches.txt
	- EXTRA_FILE
		- .well-known/.htaccess.old
		- favicon.ico

Raw output
==========
Array
(
    [core] => Array
        (
            [INVALID_HASH] => Array
                (
                    [3rdparty/guzzlehttp/guzzle/src/Client.php] => Array
                        (
                            [expected] => 34b6d5b6bf056c25c4986eef62b44dd5a8508affc120234394df55c6b9580312d19498b78398c78b55884b393f51c6997deff5c8bfd6578585c7a1fde8d9d604
                            [current] => def9cb679ae55b41a425a57ecb49bd010d948f47f5436e9c619e20fd1185fd9e9a21cc46d43c214bab69f70df771058b85c27f304bafddd54421e1aba3485fb3
                        )

                    [3rdparty/patches.txt] => Array
                        (
                            [expected] => c9c980044146368b809b774e171a2f08345c75a7c622f3153d3c2881ee06dcd9abbe3e342f3ea36b2e8e85c2f77610286de1576c60d14c3532b6ec2fca1a1e1e
                            [current] => 4e5c76601cd13c1122641fd50e47d81abdd5abe75390ab9d1cbb70e59f5d9f88e1c76dafebee17b62a1bccb0fa70b319b76511a3670cdec6398a6a1204026db2
                        )

                )

            [EXTRA_FILE] => Array
                (
                    [.well-known/.htaccess.old] => Array
                        (
                            [expected] => 
                            [current] => da87aed63619c004d66460f2dd72b4aa6ddee0960a5082825f4ca3d8fd3e419ad69f8e48eea01bd3719fd9ce40ba41deb00a4df16e13c8c9b17d946b42a1ec11
                        )

                    [favicon.ico] => Array
                        (
                            [expected] => 
                            [current] => cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e
                        )

                )

        )

)

10.0.2.1: No errors have been found.

The content of config/config.php:

9.0.4

<?php
$CONFIG = array (
  ...
  'dbtype' => 'mysql',
  'version' => '9.0.4.1',
  ...
  'logtimezone' => 'UTC',
  'installed' => true,
  'loglevel' => 2,
  'maintenance' => false,
  'htaccess.RewriteBase' => '/',
  'filelocking.enabled' => true,
  ...
);

10.0.2.1

<?php
$CONFIG = array (
  ...
  'dbtype' => 'mysql',
  'version' => '10.0.2.1',
  ...
  'logtimezone' => 'UTC',
  'installed' => true,
  'maintenance' => false,
  'filelocking.enabled' => true,
  'mail_smtpmode' => 'php',
  ...
  'loglevel' => 2,
);

Are you using external storage, if yes which one: No

Are you using encryption: No

I have seen here that maybe I have to add some extra elements to the array $allowedHosts but I haven't try it.


#2

I try the change this change in $allowedHosts:

 $ allowedHosts = [':: 1', '127.0.0.1', 'localhost', 'ns1.dreamhost.com', '173.XXX.XXX.XXX'];

It didn't work, @ViSol