Update Linux client 2.6.1 to 2.6.2 apt error (Ubuntu 19.10)

Expected behaviour

Tried to fix a broken install, but get the below error.

Actual behaviour

The following package was automatically installed and is no longer required:
Use ‘sudo apt autoremove’ to remove it.
The following additional packages will be installed:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 12 not upgraded.
1 not fully installed or removed.
Do you want to continue? [Y/n] Y
(Reading database … 255132 files and directories currently installed.)
Preparing to unpack …/ocqt5125-libsqlite0_3.29.0-1+2.1_amd64.deb …
Unpacking ocqt5125-libsqlite0:amd64 (3.29.0-1+2.1) …
dpkg: error processing archive /var/cache/apt/archives/ocqt5125-libsqlite0_3.29.0-1+2.1_amd64.deb (–unpack):
trying to overwrite ‘/opt/ownCloud/qt-5.12.5/lib/x86_64-linux-gnu/libsqlite3.so.0.8.6’, which is also in package ocqt5125-libsqlite0-dev:amd64 3.29.0-1+1.1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Steps to reproduce

  1. Upgrade 19.10 owncloud 2.6.1 to 2.6.2 client from 19.10 repositories
  2. apt complains about install
  3. Suggestion is to run sudo apt --fix-broken install

Server configuration

Operating system: Ubuntu 18.04

Web server: Apache


PHP version:

ownCloud version: 10.4.0

Storage backend (external storage):

Client configuration

Client version: 2.6.1 upgrading to 2.6.2

Operating system: Kubuntu 19.10

OS language: Linux

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client:


Please use Gist (https://gist.github.com/) or a similar code paster for longer

Template for output < 10 lines

  1. Client logfile: Output of owncloud --logwindow or owncloud --logfile log.txt
    (On Windows using cmd.exe, you might need to first cd into the ownCloud directory)
    (See also http://doc.owncloud.org/desktop/2.2/troubleshooting.html#client-logfile )

  2. Web server error log:

  3. Server logfile: ownCloud log (data/owncloud.log):

I ran into the same issue at some point in the testpilot repo.

Not sure what the exact current status of the repo is, but I posted the following workaround:

1 Like