Update own cloud with self signed certificates


Yesterday, I installed ownCloud (10.0.3)on raspberry with self signed certificate.
Today a new version is available, 10.0.9
When I try to update automatically this error appear ‘cURL error 60: SSL certificate problem: self signed certificate’.
Could you help me to update ?
Thanks for helping.
Best regards

Can't map network drive on windows 10

can you perform an manual upgrade?



It might be off-topic in times of Let’s Encrypt, but why still dealing with self signed certificates. Or did I miss something?


You still need a valid domain (€) for Let’s encrypt.

Self signed certs are free :slight_smile:


OK, that’s true, of course.


Thanks for reply. The problem with Let’s crypt is that you need domain name and not only static IP.
I found a solution to upgrade from localhost. I start automatique upgrade directly on server (raspberry). From browser to
Now upgrade start 2 hours ago and maintenance mode is always active !
An idea to fix that ?
Best regards


You’re not alone with this issue! There are tons of posts on this topic here in the forum.


That might be the problem, that there are a ton of people who run in this problem. I have raised an issue in the updater repo on github.


Thanks for reply.
Could you help me to fix ?
Best regards


connect to your raspy via SSH / Putty

Go to the ownCloud directory

Execute this occ command

sudo -u www-data php occ upgrade -vvv

then you will probably see an error message. Something like

can not upgrade, please disable the following apps.

then you disable the apps with

sudo -u www-data php occ app:disable **app**

then you run the upgrade on the command line again, and you are done.


Thanks a lot. Upgrade successful !!!
A the end how to disable maintenance mode with command line ?


sudo -u www-data php occ maintenance:mode --off



to get this information it also helps to have a look at the documentation which seems to include the required information to directly get an answer:



Thanks for helping Dmitry and alfredb.
Best regards