Update to 10.0.3 - Files Disappear Web GUI

centos
php

#1

Hello friends,

Here some details about my environment:

  • Centos 7
  • Apache 2.4.6 - PHP 7
  • MariaDB 5.5.52
  • Storage NSF mount (it is integrated in FSTAB)
  • SELinux permissive

Today when i tried to login in my owncloud i got the notification that i have to Upgrade to version 10.0.3(Why no?) i proceed to upgrade it, then i got the message that php 5.4.x is not supported for the new version of ownCloud, then i decided to upgrade to PHP7(Why not?) if faster, is stable and so on. Now I can connect to my ownCloud but when i want to see my files, there is NOTHING!!!!!! then i was really scare and I had a look at the data/ folder and everything is there. I disabled the SELinux and still nothing. From Native ownCloud App i have a webdav problem to and i can not connect.

I want to know if there is something i had to change before upgrade from 9.x or if 10.0.3 has another requirements.
The owncloud.log is showing nothing and the same in apache logs.... I have no clue what is going on...

I hope somebody had experience with something similar and can help me to solve this problem.

All the best


#2

UPDATE:

I went to the Activity App, and I had been able to see my files, and i click in then and I'm moving to the folder where the files are... but problem seems to be in the root directory when I'm going to Files app... And native owncloud App still have the same error.

Thanks


#3

Check the browser console for errors: JS console and network console. Maybe the Webdav calls that fetch the file list aren't going through.


#4

Hi PVince81,

I check i had this error in the console:
https://cloud.gonkar.com/owncloud/remote.php/webdav/

POST Raw DATA:
<?xml version="1.0"?>\n\n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n

Response Header:

Cache-Controlno-store, no-cache, must-revalidateConnectionKeep-AliveContent-Length181Content-Security-Policydefault-src 'none';Content-Typeapplication/xml; charset=utf-8DAV1, 3, extended-mkcolDateMon, 06 Nov 2017 12:10:02 GMTExpiresThu, 19 Nov 1981 08:52:00 GMTKeep-Alivetimeout=5, max=100Pragmano-cacheServerApache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/7.0.24VaryBrief,PreferX-Content-Type-OptionsnosniffX-Download-OptionsnoopenX-Frame-OptionsSAMEORIGINX-Permitted-Cross-Domain-PoliciesnoneX-Powered-ByPHP/7.0.24X-Robots-TagnoneX-XSS-Protection1; mode=block

Request Header:

Accept*/*Accept-Encodinggzip, deflate, brAccept-Languageen-US,en;q=0.5Connectionkeep-aliveContent-Length413Content-Typeapplication/xml; charset=utf-8

Response RAW Data:
<?xml version="1.0" encoding="utf-8"?>

Sabre\DAV\Exception\NotFound


Maybe somebody can see something important in this information.


#5

Post RAW DATA:

https://pastebin.com/e9Ua9qYG


#6

Try connecting to OC with a Webdav client.

From looking at the above it seems that you're getting a 404 not found for the root folder, happening on Sabre DAV level.

Did you move the data directory to another location ?


#7

I double checked the datadirectory variable in the config.php and is still te same i had before... then should be not a problem. I dont know if in this version something changed.

But for example if i write manually the path in the url I can see it:
https://cmy-owncloud.com/owncloud/index.php/apps/files/?dir=/documents&fileid=19

And i can move between dirctories and see the files and so on... the only problem seems to be the root directory.

When i click the home icon (to go to the root directory) URL: https://cloud.gonkar.com/owncloud/index.php/apps/files/?dir=/&

it is still showing me the list of items from my documents/ folder.

the Webdav client is giving me this error

I dont think is something about the server layer because i can navigate the folders anyway...


#8

Did you move the data directory to another location after upgrading ?

Check that all home directory paths are correct in the oc_accounts table