Update via Linux Paket-Manager und anschließende manuelle Installation schlägt fehl

8.2.x
update

#1

Hallo zusammen,

ich habe bereits seit einiger Zeit OC 8 im Einsatz, bisher ohne Probleme, auch im Bezug von durchgeführten Updates. Nach diesem Update jedoch ist die Installation instabil und zumindest WebDAV ohne Funktion.

Schritte zum Reproduzieren
1. sudo apt-get update
2. sudo apt-get-upgrade
3.

Erwartetes Verhalten
Ich habe heute einfach erneut ein Update via Paket-Manager durchgeführt, was jedoch fehlgeschlagen ist. Die manuelle Installation, die als Pflicht dann vorgegeben wurde, ist zwar durchgelaufen, jedoch wird das WebDAV ist beschädigt dargestellt.

Aktuelles Verhalten
während des Installation wird folgender Fehler ausgegeben:
An unhandled exception has been thrown:
exception 'Doctrine\DBAL\DBALException' with message 'Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] No such file or directory' in /var/www/owncloud/lib/private/db/connection.php:52
Stack trace:

0 /var/www/owncloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()

1 /var/www/owncloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()

2 /var/www/owncloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()

3 /var/www/owncloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(621): Doctrine\DBAL\Connection->getDatabasePlatform()

4 /var/www/owncloud/lib/private/db/connection.php(135): Doctrine\DBAL\Connection->setTransactionIsolation(2)

5 /var/www/owncloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\DB\Connection->__construct(Array, Object(Doctrine\DBAL\Driver\PDOMySql\Driver), Object(Doctrine\DBAL\Configuration), Object(Doctrine\Common\EventManager))

6 /var/www/owncloud/lib/private/db/connectionfactory.php(118): Doctrine\DBAL\DriverManager::getConnection(Array, Object(Doctrine\DBAL\Configuration), Object(Doctrine\Common\EventManager))

7 /var/www/owncloud/lib/private/server.php(330): OC\DB\ConnectionFactory->getConnection('mysql', Array)

8 /var/www/owncloud/3rdparty/pimple/pimple/src/Pimple/Container.php(112): OC\Server->OC{closure}(Object(OC\Server))

9 /var/www/owncloud/lib/private/appframework/utility/simplecontainer.php(104): Pimple\Container->offsetGet('DatabaseConnect...')

10 /var/www/owncloud/lib/private/server.php(765): OC\AppFramework\Utility\SimpleContainer->query('DatabaseConnect...')

11 /var/www/owncloud/lib/private/db.php(42): OC\Server->getDatabaseConnection()

12 /var/www/owncloud/lib/private/server.php(237): OC_DB::getConnection()

13 /var/www/owncloud/3rdparty/pimple/pimple/src/Pimple/Container.php(112): OC\Server->OC{closure}(Object(OC\Server))

14 /var/www/owncloud/lib/private/appframework/utility/simplecontainer.php(104): Pimple\Container->offsetGet('AppConfig')

15 /var/www/owncloud/lib/private/server.php(704): OC\AppFramework\Utility\SimpleContainer->query('AppConfig')

16 /var/www/owncloud/lib/private/server.php(375): OC\Server->getAppConfig()

17 /var/www/owncloud/3rdparty/pimple/pimple/src/Pimple/Container.php(112): OC\Server->OC{closure}(Object(OC\Server))

18 /var/www/owncloud/lib/private/appframework/utility/simplecontainer.php(104): Pimple\Container->offsetGet('AppManager')

19 /var/www/owncloud/lib/private/server.php(931): OC\AppFramework\Utility\SimpleContainer->query('AppManager')

20 /var/www/owncloud/lib/private/app.php(259): OC\Server->getAppManager()

21 /var/www/owncloud/lib/private/app.php(104): OC_App::getEnabledApps()

22 /var/www/owncloud/lib/base.php(564): OC_App::loadApps(Array)

23 /var/www/owncloud/lib/base.php(1083): OC::init()

24 /var/www/owncloud/console.php(42): require_once('/var/www/ownclo...')

25 /var/www/owncloud/occ(11): require_once('/var/www/ownclo...')

26 {main}Entpacken von owncloud-server (8.2.10-1.1) über (8.2.8-1.1) .

Server-Konfiguration
Betriebssystem: Ubuntu 14.04 LTS
Webserver-Typ: Apache2
Datenbank-Typ: MySQL
PHP-Version: 5.5.9
ownCloud-Version (siehe ownCloud Administrationsseite):8.2.10 (stable)
Von einer älteren ownCloud-Version aktualisiert oder neu installiert?: nein
Sonderkonfigurationen (external storage, external authentication, reverse proxy, server-side-encryption):
nein
ownCloud log (data/owncloud.log)
{"reqId":"3EHtIujNZM2EcPOHRIHs","remoteAddr":"88.153.185.245","app":"PHP","message":"fopen(\/var\/www\/owncloud\/config\/config.php): faile
d to open stream: No such file or directory at \/var\/www\/owncloud\/lib\/private\/config.php#188","level":3,"time":"2016-02-03T08:42:16+00
:00"}
{"reqId":"weJMcvTPaFjC5L2wlLF\/","remoteAddr":"88.153.185.245","app":"PHP","message":"Undefined offset: 0 at \/var\/www\/owncloud\/lib\/pri
vate\/setup\/mysql.php#45","level":3,"time":"2016-02-03T08:55:59+00:00"}
{"reqId":"ObiSQbCumY1rHCoxBCwO","remoteAddr":"88.153.185.245","app":"PHP","message":"Cannot modify header information - headers already sen
t by (output started at \/var\/www\/owncloud\/3rdparty\/sabre\/http\/lib\/Sapi.php:70) at \/var\/www\/owncloud\/3rdparty\/sabre\/http\/lib\
/Sapi.php#58","level":3,"time":"2016-02-03T11:30:54+00:00"}
{"reqId":"5t6ExKWo3kCXhjqzNYvw","remoteAddr":"88.153.185.245","app":"PHP","message":"Undefined index: permissions at \/var\/www\/owncloud\/
lib\/private\/files\/fileinfo.php#177","level":3,"time":"2016-02-07T11:00:26+00:00"}
{"reqId":"5t6ExKWo3kCXhjqzNYvw","remoteAddr":"88.153.185.245","app":"PHP","message":"Undefined index: permissions at \/var\/www\/owncloud\/
lib\/private\/files\/fileinfo.php#177","level":3,"time":"2016-02-07T11:00:26+00:00"}
{"reqId":"igTrsUXDpovwN63JyXph","remoteAddr":"88.153.185.245","app":"PHP","message":"Undefined index: permissions at \/var\/www\/owncloud\/
lib\/private\/files\/fileinfo.php#177","level":3,"time":"2016-02-07T11:00:33+00:00"}
{"reqId":"igTrsUXDpovwN63JyXph","remoteAddr":"88.153.185.245","app":"PHP","message":"Undefined index: permissions at \/var\/www\/owncloud\/
lib\/private\/files\/fileinfo.php#177","level":3,"time":"2016-02-07T11:00:33+00:00"}
{"reqId":"kyt7P9cOUjKzRgaDC1vZ","remoteAddr":"88.153.185.245","app":"PHP","message":"Undefined index: permissions at \/var\/www\/owncloud\/
lib\/private\/files\/fileinfo.php#177","level":3,"time":"2016-02-07T11:00:35+00:00"}
{"reqId":"kyt7P9cOUjKzRgaDC1vZ","remoteAddr":"88.153.185.245","app":"PHP","message":"Undefined index: permissions at \/var\/www\/owncloud\/
lib\/private\/files\/fileinfo.php#177","level":3,"time":"2016-02-07T11:00:35+00:00"}
{"reqId":"wWTqREJq5mSQS1HMo2Qe","remoteAddr":"88.153.185.245","app":"PHP","message":"Undefined index: permissions at \/var\/www\/owncloud\/
lib\/private\/files\/fileinfo.php#177","level":3,"time":"2016-02-07T11:00:39+00:00"}
{"reqId":"wWTqREJq5mSQS1HMo2Qe","remoteAddr":"88.153.185.245","app":"PHP","message":"Undefined index: permissions at \/var\/www\/owncloud\/
lib\/private\/files\/fileinfo.php#177","level":3,"time":"2016-02-07T11:00:39+00:00"}
{"reqId":"sI6FC8uZGr1wyiMDKLi7","remoteAddr":"88.153.185.245","app":"webdav","message":"Exception: {\"Message\":\"HTTP\\/1.1 423 \\"K\u0
0f6lner Gro\u00dfmarkt\\/Besprechnungsprotokolle\\/2016\\/2016-01-18 Protokoll AK-Treffen.doc\\" is locked\",\"Exception\":\"OC\\Con
nector\\Sabre\\Exception\\FileLocked\",\"Code\":0,\"Trace\":\"#0 \\/var\\/www\\/owncloud\\/3rdparty\\/sabre\\/dav\\/lib\\/DAV
\\/CorePlugin.php(635): OC\\Connector\\Sabre\\ObjectTree->move('K??lner Gro??ma...', 'K??lner Gro??ma...')\n#1 [internal function]:
Sabre\\DAV\\CorePlugin->httpMove(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#2 \\/var\\/www\\/owncloud\
\/3rdparty\\/sabre\\/event\\/lib\\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#3 \\/var\\/www\\/owncloud\\/3
rdparty\\/sabre\\/dav\\/lib\\/DAV\\/Server.php(469): Sabre\\Event\\EventEmitter->emit('method:MOVE', Array)\n#4 \\/var\\/www\\
/owncloud\\/3rdparty\\/sabre\\/dav\\/lib\\/DAV\\/Server.php(254): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Reques
t), Object(Sabre\\HTTP\\Response))\n#5 \\/var\\/www\\/owncloud\\/apps\\/files\\/appinfo\\/remote.php(56): Sabre\\DAV\\Serve
r->exec()\n#6 \\/var\\/www\\/owncloud\\/remote.php(137): require_once('\\/var\\/www\\/ownclo...')\n#7 {main}\",\"File\":\"\\/var\
\/www\\/owncloud\\/lib\\/private\\/connector\\/sabre\\/objecttree.php\",\"Line\":239}","level":4,"time":"2016-02-08T11:38:20+00:00"}
{"reqId":"CpJaz+IpbjzRJDl9oTAc","remoteAddr":"88.153.185.245","app":"webdav","message":"Exception: {\"Message\":\"HTTP\\/1.1 423 \\"K\u0
0f6lner Gro\u00dfmarkt\\/Besprechnungsprotokolle\\/2014\\/2014-09-01 Protokoll Marktamt Anwesenheitsliste.tif\\" is locked\",\"Excepti
on\":\"OC\\Connector\\Sabre\\Exception\\FileLocked\",\"Code\":0,\"Trace\":\"#0 \\/var\\/www\\/owncloud\\/3rdparty\\/sabre\\/d
av\\/lib\\/DAV\\/CorePlugin.php(82): OC\\Connector\\Sabre\\File->get()\n#1 [internal function]: Sabre\\DAV\\CorePlugin->httpG
et(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#2 \\/var\\/www\\/owncloud\\/3rdparty\\/sabre\\/event\\/li
b\\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#3 \\/var\\/www\\/owncloud\\/3rdparty\\/sabre\\/dav\\/lib\\/D
AV\\/Server.php(469): Sabre\\Event\\EventEmitter->emit('method:GET', Array)\n#4 \\/var\\/www\\/owncloud\\/3rdparty\\/sabre\\/da
v\\/lib\\/DAV\\/Server.php(254): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response
))\n#5 \\/var\\/www\\/owncloud\\/apps\\/files\\/appinfo\\/remote.php(56): Sabre\\DAV\\Server->exec()\n#6 \\/var\\/www\\/own
cloud\\/remote.php(137): require_once('\\/var\\/www\\/ownclo...')\n#7 {main}\",\"File\":\"\\/var\\/www\\/owncloud\\/lib\\/private
\\/connector\\/sabre\\/file.php\",\"Line\":277}","level":4,"time":"2016-02-08T13:17:02+00:00"}
{"reqId":"0erQLTduW\/yQ\/4Is1et+","remoteAddr":"88.153.185.245","app":"core","message":"Could not get categories: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:29:01+00:00"}
{"reqId":"EOwc61H\/93VMT8obq6mU","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:29:02+00:00"}
{"reqId":"EOwc61H\/93VMT8obq6mU","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:29:02+00:00"}
{"reqId":"EOwc61H\/93VMT8obq6mU","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:29:02+00:00"}
{"reqId":"EOwc61H\/93VMT8obq6mU","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:29:02+00:00"}
{"reqId":"tcSux6DGBy\/HaV3ujCHC","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:29:28+00:00"}
{"reqId":"tcSux6DGBy\/HaV3ujCHC","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:29:28+00:00"}
{"reqId":"tcSux6DGBy\/HaV3ujCHC","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:29:28+00:00"}
{"reqId":"tcSux6DGBy\/HaV3ujCHC","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:29:28+00:00"}
{"reqId":"\/iSsFsMUbJ5J2PMfEnCZ","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:30:28+00:00"}
{"reqId":"\/iSsFsMUbJ5J2PMfEnCZ","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:30:28+00:00"}
{"reqId":"\/iSsFsMUbJ5J2PMfEnCZ","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:30:28+00:00"}
{"reqId":"\/iSsFsMUbJ5J2PMfEnCZ","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:30:28+00:00"}
{"reqId":"3gB1W2MnFt0pBAWLDkak","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:30:34+00:00"}
{"reqId":"3gB1W2MnFt0pBAWLDkak","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:30:35+00:00"}
{"reqId":"3gB1W2MnFt0pBAWLDkak","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:30:35+00:00"}
{"reqId":"3gB1W2MnFt0pBAWLDkak","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:30:35+00:00"}
{"reqId":"5DnTywABEiFRXLKdjycK","remoteAddr":"88.153.185.245","app":"core","message":"Could not get categories: cURL error 7: Failed to con
nect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:20+00:00"}
{"reqId":"W+gh5b9X1XnW9w+Widss","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:20+00:00"}
{"reqId":"W+gh5b9X1XnW9w+Widss","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:20+00:00"}
{"reqId":"yoBSzJAjruL+h1Rb9Rqe","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:30+00:00"}
{"reqId":"yoBSzJAjruL+h1Rb9Rqe","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:30+00:00"}
{"reqId":"yoBSzJAjruL+h1Rb9Rqe","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:30+00:00"}
{"reqId":"yoBSzJAjruL+h1Rb9Rqe","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:30+00:00"}
{"reqId":"W4cPf9dgqRb4If\/8blqA","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:34+00:00"}
{"reqId":"W4cPf9dgqRb4If\/8blqA","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:34+00:00"}
{"reqId":"W4cPf9dgqRb4If\/8blqA","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:34+00:00"}
{"reqId":"W4cPf9dgqRb4If\/8blqA","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to c
onnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:34+00:00"}
{"reqId":"yAGCdgaeCdNXuaXO498U","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:39+00:00"}
{"reqId":"yAGCdgaeCdNXuaXO498U","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:39+00:00"}
{"reqId":"yAGCdgaeCdNXuaXO498U","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:39+00:00"}
{"reqId":"yAGCdgaeCdNXuaXO498U","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:31:39+00:00"}
{"reqId":"aVoY2GXXr8deOCNTNBeQ","remoteAddr":"88.153.185.245","app":"core","message":"Could not get categories: cURL error 7: Failed to con
nect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:07+00:00"}
{"reqId":"Ujtog5LhH0vi1uosn2ap","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:08+00:00"}
{"reqId":"Ujtog5LhH0vi1uosn2ap","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:08+00:00"}
{"reqId":"Ujtog5LhH0vi1uosn2ap","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:08+00:00"}
{"reqId":"Ujtog5LhH0vi1uosn2ap","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:08+00:00"}
{"reqId":"v3xBbnINtBUhdpYtfTPT","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:10+00:00"}
{"reqId":"v3xBbnINtBUhdpYtfTPT","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:10+00:00"}
{"reqId":"v3xBbnINtBUhdpYtfTPT","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:10+00:00"}
{"reqId":"iM9FsXnO2FGFq4iPfFxQ","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:14+00:00"}
{"reqId":"iM9FsXnO2FGFq4iPfFxQ","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:14+00:00"}
{"reqId":"iM9FsXnO2FGFq4iPfFxQ","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:14+00:00"}
{"reqId":"iM9FsXnO2FGFq4iPfFxQ","remoteAddr":"88.153.185.245","app":"core","message":"Could not get application: cURL error 7: Failed to co
nnect to api.owncloud.com port 443: Connection refused","level":3,"time":"2016-02-14T12:34:14+00:00"}
{"reqId":"w82BVCkxMc\/Be1J6eMjY","remoteAddr":"62.143.126.67","app":"PHP","message":"Undefined index: extension at \/var\/www\/owncloud\/li
b\/private\/installer.php#267","level":3,"time":"2016-02-16T08:04:56+00:00"}
{"reqId":"RTE2A6TvvCDc7NDmTEp7","remoteAddr":"62.143.126.67","app":"PHP","message":"Undefined offset: 1 at \/var\/www\/owncloud\/apps\/mail
\/vendor\/pear-pear.horde.org\/Horde_Smtp\/Horde\/Smtp.php#1048","level":3,"time":"2016-02-16T08:07:17+00:00"}
{"reqId":"RTE2A6TvvCDc7NDmTEp7","remoteAddr":"62.143.126.67","app":"PHP","message":"fwrite(): send of 8192 bytes failed with errno=11 Resou
rce temporarily unavailable at \/var\/www\/owncloud\/apps\/mail\/vendor\/pear-pear.horde.org\/Horde_Smtp\/Horde\/Smtp\/Connection.php#92","
level":3,"time":"2016-02-16T08:07:21+00:00"}
{"reqId":"RTE2A6TvvCDc7NDmTEp7","remoteAddr":"62.143.126.67","app":"PHP","message":"fwrite(): send of 8192 bytes failed with errno=11 Resou
rce temporarily unavailable at \/var\/www\/owncloud\/apps\/mail\/vendor\/pear-pear.horde.org\/Horde_Smtp\/Horde\/Smtp\/Connection.php#92","
level":3,"time":"2016-02-16T08:07:24+00:00"}
{"reqId":"RTE2A6TvvCDc7NDmTEp7","remoteAddr":"62.143.126.67","app":"PHP","message":"Undefined offset: 1 at \/var\/www\/owncloud\/apps\/mail
\/vendor\/pear-pear.horde.org\/Horde_Smtp\/Horde\/Smtp.php#1048","level":3,"time":"2016-02-16T08:07:24+00:00"}
{"reqId":"RTE2A6TvvCDc7NDmTEp7","remoteAddr":"62.143.126.67","app":"PHP","message":"fwrite(): send of 8192 bytes failed with errno=11 Resou
rce temporarily unavailable at \/var\/www\/owncloud\/apps\/mail\/vendor\/pear-pear.horde.org\/Horde_Smtp\/Horde\/Smtp\/Connection.php#92","
level":3,"time":"2016-02-16T08:07:28+00:00"}
{"reqId":"RTE2A6TvvCDc7NDmTEp7","remoteAddr":"62.143.126.67","app":"PHP","message":"fwrite(): send of 8192 bytes failed with errno=11 Resou
rce temporarily unavailable at \/var\/www\/owncloud\/apps\/mail\/vendor\/pear-pear.horde.org\/Horde_Smtp\/Horde\/Smtp\/Connection.php#92","
level":3,"time":"2016-02-16T08:07:31+00:00"}
{"reqId":"RTE2A6TvvCDc7NDmTEp7","remoteAddr":"62.143.126.67","app":"PHP","message":"Allowed memory size of 536870912 bytes exhausted (tried
to allocate 46137185 bytes) at \/var\/www\/owncloud\/3rdparty\/phpseclib\/phpseclib\/phpseclib\/Crypt\/Base.php#946","level":3,"time":"201
6-02-16T08:07:34+00:00"}
{"reqId":"HDA0vil5oDMq3VSahuUQ","remoteAddr":"62.143.126.67","app":"PHP","message":"Undefined index: addressBookId at \/var\/www\/owncloud\
/apps\/contacts\/lib\/hooks.php#109","level":3,"time":"2016-02-16T08:12:04+00:00"}
{"reqId":"R7N\/v9Pbcqa488Ti5pfM","remoteAddr":"62.143.126.67","app":"contacts","message":"Exception: {\"Exception\":\"Exception\",\"Message
\":\"Fehlender Gruppenname bei der Anfrage.\",\"Code\":412,\"Trace\":\"#0 [internal function]: OCA\\Contacts\\Controller\\GroupContro
ller->addToGroup()\n#1 \\/var\\/www\\/owncloud\\/lib\\/private\\/appframework\\/http\\/dispatcher.php(159): call_user_func_array(A
rray, Array)\n#2 \\/var\\/www\\/owncloud\\/lib\\/private\\/appframework\\/http\\/dispatcher.php(89): OC\\AppFramework\\Http\\
\Dispatcher->executeController(Object(OCA\\Contacts\\Controller\\GroupController), 'addToGroup')\n#3 \\/var\\/www\\/owncloud\\/l
ib\\/private\\/appframework\\/app.php(108): OC\\AppFramework\\Http\\Dispatcher->dispatch(Object(OCA\\Contacts\\Controller\\G
roupController), 'addToGroup')\n#4 \\/var\\/www\\/owncloud\\/lib\\/public\\/appframework\\/app.php(134): OC\\AppFramework\\App:
:main('GroupController', 'addToGroup', Object(OC\\AppFramework\\DependencyInjection\\DIContainer))\n#5 \\/var\\/www\\/owncloud\\
/apps\\/contacts\\/appinfo\\/routes.php(445): OCP\\AppFramework\\App->dispatch('GroupController', 'addToGroup')\n#6 [internal funct
ion]: OC\\Route\\Router->OCA\\Contacts\\AppInfo\\{closure}(Array)\n#7 \\/var\\/www\\/owncloud\\/lib\\/private\\/route\\/r

Dies ist der aktuellste Teil der log.

Nach dem Fehler habe ich die Installation manuell durchgeführt:

  1. cd /var/www/owncloud/
  2. sudo -u www-data php occ upgrade

Protokoll:
Set log level to debug - current level: 'Warning'
Checking whether the database schema can be updated (this can take a long time depending on the database size)
Checked database schema update
Checking updates of apps
Checked database schema update for apps
Updating database schema
Updated database
Disabled 3rd-party app: bookmarks
Disabled 3rd-party app: calendar
Disabled 3rd-party app: contacts
Disabled 3rd-party app: documents
Disabled 3rd-party app: mail
Disabled 3rd-party app: tasks
Update 3rd-party app: mail
Update successful
Maintenance mode is kept active
Reset log level to 'Warning'

Anschließend habe ich den Wartungsmodus beendet:

  1. sudo -u www-data php occ maintenance:mode --off

Im Webbrwoser erhalte ich nun folgende Meldung:
Ihr Webserver ist noch nicht hinreichend für Datei-Synchronisation konfiguriert, weil die WebDAV-Schnittstelle vermutlich defekt ist.

Bitte füge mögliche Fehler in den folgenden Code-Block, siehe https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 für mehr info.

Integrity status für oC9+

Logge Dich als Admin in Deine ownCloud Instanz ein, öffne
http://example.com/index.php/settings/integrity/failed
und kopiere das Ergebnis hier.

#2

Ich habe die manuelle Installation wie unter
https://doc.owncloud.org/server/8.0/admin_manual/maintenance/upgrade.html
beschrieben durchgeführt.

Die Anleitung enthält jedoch Fehler:

Unter "Manual Upgrade Procedure" sind folgende Punkte unrichtig dargestellt:

Zwischen Schritt 4 und 5 fehlt der Schritt des Entpackens der Archivdatei.
Vor Schritt 9 fehlt die Deaktivierung des Wartungsmodus. Ohne die Deaktivierung kann ein Update nicht durchgeführt werden.

In Schritt 9 sollte bei dem Update via Shell auch der Verzeichniswechsel beschrieben werden. Z.B. wie folgt:
cd /var/www/owncloud
sudo -u www-data php occ upgrade

Leider ist folgender Befehl fehlerhaft, d.h. ohne die notwendige Wirkung:

sudo -u www-data php occ maintenance:mode --off

Ein möglicherweise aktiver Single-mode (hier nach dem zuvor beschriebenen Problem beim Update) wird nicht deaktiviert und erfodert eine manulle Änderung in der config/config.php, hier bei 'singleuser' ==> false, eintragen.

Problem ist nun behoben, Installation läuft nun mit 8.2.10 (stable).


#3

Hi,

sollte es Fehler in der Anleitung geben wird das posten dieser Fehler hier nichts bringen da dieses nicht bemerkt wird. Bitte melde solche Dinge immer direkt in [1], sonst war Deine Mühe beim Posten dieser Fehler umsonst.

[1]