Update vom 10.1.1 to 10.2.1

OC runs on a shared server, installed through cPaneel --> Softaculous Apps installer.

Until now I got notification to update and it was possible to update the installation through the Softaculous Updater.

This time no notification, I contacted Softaculous and got following answer:

Sure we understand your concern.
However the minimum version of the script to upgrade at “10.2.1” is “10.2.0”.
This is the script vendor requirements and hence we have also made as the minimum requirement.

Tried to update with the Updater from the admin page and get following error:

Client error response [url] https://localhost/index.php/occ/config:list [status code] 404 [reason phrase] Not Found

Any solution, dont really want to make an new install.

Thank you for reading and any help.


from what i have read in the past this isn’t valid anymore since ownCloud 10 and you could update from 10.1.1 to 10.2.1 directly.

Problem is I am on a shared server and have no shell access. Thats why I could only update through cPannel --> Softaculous.

Unless somebody can tell me another way, except a new installation.


i think its not a good idea to switch from one updating method (Softaculous Updater) to another (the ownCloud Updater) as it could be possible that both update ways are not compatible.

Maybe you could contact Softaculous to let them know that requirement about the version doesn’t apply anymore?

I have tried this but they are reluctand to accept this.
However I contacted them again with the comments you posted, will see what they say.

1 Like

Well it came as it had to come, thats part of the reply from Softaculous.

Yes the upgrade is possible but this needs to be done manually.
This is because in such case the upgrade is not possible but a migration utility needs to be executed.

So no chance and as it looks no solution from here as well. :frowning:

Well I was able to make the Upgrade through cPanel --> File Manager. Latest version is up and running.