Updater error - cURL error 60: Peer's Certificate issuer is not recognized

hosting

#1

Hi
I would like to use the autoupdate function of owncloud,
but I get the error in the subject.

Any suggestion, please?


#2

Are your server's ssl certs up to date?

On Ubuntu/Debian you can use http://manpages.ubuntu.com/manpages/xenial/man8/update-ca-certificates.8.html to do so


#3

hi
thanks for your reply. modifications were made on the server, and now the error changed to :
"cURL error 35: SSL received a record that exceeded the maximum permissible length."

which are the modifications needed now?

thanks


#4

Where are you receiving this error?
What is the distribution/OS you are running on?


#5

trying to run the autoupdater.
CentOS Linux 7.3.1611 (Core)‬


#6

Can I see some screenshot please for better understanding? THX


#7

#8

#9

Did you google for this error? Looks like an apache ssl miss-configuration


#10

I've asked for additional help from my hosting company, but the error remains.
these are the modifications made to tr to solve it.


We are getting below error while try to update the Owncloud.

cURL error 35: SSL received a record that exceeded the maximum permissible length.

Initially there was an issue with the SSL certificate installed on the doamin 'imcdcloud.com' which was corrected.

We then searched many forums and as per their recommendation we made below changes on the server.
1: Made the below entry in Apache configuration file.



ServerName cloud.owncloud.com
Header always add Strict-Transport-Security "max-age=15768000; includeSubDomains; preload"


2: Set open_basedir = none in php.ini file, but it didn't helped.

Hence, we requested you to get in touch with Owncloud support and let us know what they have to say. Please get in touch with them and let us know their feedback so that we can investigate further accordingly.


suggestions please?


#11

I don't see that any of those done changes could solve this issue. So i think the suggestion to search for that error on google stays. As an alternative you can always do a manual update without using the updater app.


#12

Hi nick2011

i stumbled upon the same issue as you. This PR https://github.com/owncloud/updater/pull/441 fixes the problem. You can grab it from GitHub. If you don't know how to apply it please write us here. Hope it helps.

Looking forward to hearing from you

David


#13

hi davitol
thanks for the update.
I will check that tomorrow.

Can you plese tell me how to update the patch?
thanks again


#14

Hi
After applying the patch, the error turned to
"cURL error 35: See http://curl.haxx.se/libcurl/c/libcurl-errors.html"

asked the company to check ahd this is their reply

" CURL is already enabled on the server correctly."

suggestions?


#15

Maybe follow this suggestion:


#16

I don't want to make a manual upgrade but to fix the function of automatic upgrade!


#17

Its nearly 1 1/2 month since your initial post and you havn't found a solution yet. Don't you think its easier to just do the manual upgrade?

And if there is an issue with the updater itself it could be also possible that it is fixed in a newer release you currently can't upgrade to due to your issue.


#18

considering that it's impossible to have this nice function working...
I think I will try the manual upgrade.

Can this be done directly from 9.1.5 to 10.0.x?


#19

hello... I'm looking for someone able to help me with this upgrade.
anyone available? I can hire someone, if needed.

Pleaaseee