Updater »Unable to move«: ownCloud 8.1.4. -> 8.1.11

update_issue
updater
update

#1

Hi,
yes, I'm very late :wink: I have trouble updating my ownCloud.
Error and log attached.

Could you help here please?
Thanks a million!

Error message of updater (UI):
Update fehlgeschlagen.Unable to move /www/htdocs/PAGE/cloud.PAGE.de/_oc-upgrade/8.1.11/core/core to /www/htdocs/PAGE/cloud.PAGE.de/core

Log:

  • opendir(/tmp): failed to open dir: Permission denied at /www/htdocs/PAGE/cloud.PAGE.de/lib/private/tempmanager.php#179
  • Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. at Unknown#0
  • rename(/www/htdocs/PAGE/cloud.PAGE.de/_oc-upgrade/8.1.11/core/core,/www/htdocs/PAGE/cloud.PAGE.de/core): Directory not empty at /www/htdocs/PAGE/cloud.PAGE.de/apps/updater/lib/helper.php#45
  • in_array() expects parameter 2 to be array, null given at /www/htdocs/PAGE/cloud.PAGE.de/apps/updater/lib/location/core.php#35
  • Undefined index: 8.1 at /www/htdocs/PAGE/cloud.PAGE.de/apps/updater/lib/location/core.php#26
  • Success: 3rdparty
  • Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. at Unknown#0

Beste, Tobi


#2

The updater app hangs at some points, it depends a bit on the settings. You can report it to the bugtracker: https://github.com/owncloud/updater/issues.

For more reliable updates, please use the manual upgrade:
https://doc.owncloud.org/server/latest/admin_manual/maintenance/manual_upgrade.html


#3

I don't think that stuff is fixed in such an outdated version of the updater app.

+1 for the manual upgrade


#4

It could be fixed for newer versions. So then, there is no real way around the manual upgrade.


#5

Yes, if the issue would have happended in oC 9.0, 9.1 or 10.0 . But the OP is using the "old" updater app from 8.1 so the issue (or better the code) most likely doesn't exist anymore in the rewritten updater app of oC 9.0+