Upgrade app dav can't be disabled


I’m stuck in upgrade process from to 10.3.2

the app list command show “dav” is enabled.
When running the occ command for disabling it the message “dav can’t be disabled”

  • Following different troubleshooting tips I already tried to delete the dav folder in apps
  • Tried to set the configvalue to “no” in DB

both with no success
When starting upgrade following message comes up:

Repair warning: You have incompatible or missing apps enabled that could not be found or updated via the marketplace.
Repair warning: Please install or update the following apps manually or disable them with:
occ app:disable dav
Repair warning: For manually updating, see https://doc.owncloud.org/server/10.3/go.php?to=admin-marketplace-apps
OC\RepairException: Upgrade is not possible
Update failed

Don’t know where I got this app and how I can get rid of it.

Thanks for your help

Steps to reproduce

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:

Web server:


PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration


Operating system:


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

Can you extract the dav from the ownCloud version you’re trying to install, copy it back in to where it should be (most likely /path/to/your/owncloud/apps) and then try again?

I assume currently the path /path/to/your/owncloud/apps/dav is empty


I copied the folder from running installation to the new one when the error message first came up when upgrading.
Folders not empty at the moment.

I turned off maintenance and brouht the old installation up again.
The “Dav” app is shown as enabled and can’t be disabled like I wrote before,
but I can’t find it on the market or in the app overview in the GUI.
Can I reset these settings maybe? I guess the only reference can be found
in the database (MariaDB).


i think the “dav” app is directly included in the ownCloud installation packages. Could it be possible that you have some older files kept during the upgrade?

In the past i always did my upgrades in a way that i had cleaned up my ownCloud installation directory and only kept the “/data”, “/config” and “/apps-external” folder and then copied over the new files from the current ownCloud release.


i usually leave the folder with a version number and only create a softlink named “owncloud”. So it is easier to have an overview regarding version and so on.
I created an owncloud-10.3.2 folder and put the new files there. So I only copied the config.php file.
My data folder is on another partition on the server and should not be touched by the update afaik.

In my installation there is no “apps-external” folder available.
When I extracted the new files to owncloud-10.3.2 I didn’t copy the apps folder, so I was surprised that the old apps showed up for updating, which didn’t work obviously.


yes i think this could be the problem of your issue. If you don’t copy over the apps folder then i think ownCloud has the knowledge about the “older” dav app in its database and knows that the app isn’t compatible but can’t update it due to the missing newer files .

OK, so do you think that messed the things up already?
The weird thing is, that I can’t see the DAV app in the running version as well.
So I can’t remove or update it in the market. I will try to copy a app folders to the
folder of the new version.