Upgrade fails tot 10.0.2

hosting

#1

When running the upgrade to 10.0.2 I get errors and update wasn't succesfull:

Any tips?

Paste of the log:
Reparatiewaarschuwing:Exception
Reparatiewaarschuwing:Archiefbestanden van type application/octet-stream niet ondersteund
Reparatiewaarschuwing:Exception
Reparatiewaarschuwing:Archiefbestanden van type application/octet-stream niet ondersteund
Reparatiewaarschuwing:Exception
Reparatiewaarschuwing:Archiefbestanden van type application/octet-stream niet ondersteund
Reparatiewaarschuwing:Exception
Reparatiewaarschuwing:Archiefbestanden van type application/octet-stream niet ondersteund
Reparatiewaarschuwing:Exception
Reparatiewaarschuwing:Archiefbestanden van type application/octet-stream niet ondersteund
Reparatiewaarschuwing:Exception
Reparatiewaarschuwing:Archiefbestanden van type application/octet-stream niet ondersteund
Reparatiewaarschuwing:You have incompatible or missing apps enabled that could not be found or updated via the marketplace.
Reparatiewaarschuwing:please install app manually with tarball or disable them with: occ app:disable activity occ app:disable calendar occ app:disable files_pdfviewer occ app:disable files_texteditor occ app:disable gallery


#2

Hi bartmans,

Well, the log message already says pretty clear what the error is: you have to disable the activity, calendar, files_pdfviewer, files_texteditor and gallery apps. This is because those apps are now made available on https://marketplace.owncloud.com/.

After disabling those apps by using the occ app:disable command the upgrade process should go through successfully.


#3

Thx for your quick response. I have no access to CLI, so I used phpmyadmin to disable the plugins.

OC 10 indeed finished upgrade. I then went to the marketplace, to install new version of Calendar. I got the same error:
Archiefbestanden van type application/octet-stream niet ondersteund.

I then tried update the Marketplace app itself. Same error.

Is this something I can fix myself? Or can you explain what I need to ask my hoster.

I'm back on OC 9 in the mean time.


#4

Hmm I am not sure to be honest. Do you have the PHP module zip installed ?
Depending on the distribution this can have different names. For instance on Ubuntu 16.04 running the default PHP version, this is called php7.0-zip.


#5

I installed using cPanel / Installatron, so are using those defaults. Checked phpino()

zip
Zip enabled
Zip version 1.12.5
Libzip version 0.11.2

So it appears Zip is enabled. Also saw am using PHP 5.6 but that falls within the requirements for OC 10 I thought.


#6

Yes, PHP 5.6 is fine. Do you have the possibility to check if the tar package is installed ?


#7

Fixed.

In cPanel I selected PHP 7 (although not the issue, I thought why not) and could then set some options for PHP. The error log complained about:
method":"REPORT","url":"\/bestanden\/remote.php\/dav\/calendars\/bla\/personal\/","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead.

So I checked if the 'intl' extension was set. It wasn't so I enabled intl and could update flawlessly.

@Pako81 thanks for your quick responses!


#8

Nice :slight_smile: Glad to hear that