Upgrade from 9.0.11 failing

upgrade
9.0.x
9.1.x
10

#1

Hi everybody,

after some very tedious upgrading through multiple owncloud versions I have encountered a point where I can not progress any further: 9.0.11 Any further version I have tried in order to finally get into the latest version 10 gives me the typical upgrade error regarding multiple versions (see template below).
I have looked through the forum and google results for quite a while now and also tried to find any newer minor release of 9.0 after 11, but that seems to be indeed the direct predecessor of 9.1. No luck so far.
I really want to upgrade my instance, as the client now keeps complaining about the server version being unsupported and I hope someone here can give me any advice of how to proceed.

Cheers

Alex

Steps to reproduce

  1. Owncloud server version 9.0.11 upgraded in multiple steps back from 8.1.6
  2. Download either 9.1.0, 9.1.8, 10.0.0, 10.0.9 or 10.0.10
  3. Upgrade manually via occ upgrade or via the web interface

Expected behaviour

Upgrade to newer version

Actual behaviour

Exception: Updates between multiple major versions and downgrades are unsupported.
Update failed

Server configuration

Operating system:
Latest Raspbian Server

Web server:
Latest Apache

Database:
Sqlite

PHP version:
7.0

ownCloud version: (see ownCloud admin page)
9.0.11

Updated from an older ownCloud or fresh install:
Updated in multiple steps from 8.1.6


#2

Hey,

if i understand the recent discussion on the upgrade of such an older version below you could upgrade directly from 8.2.11 to 10.0.10 without going via any of the versions 9:


#3

Hi Tom,
that was what I tried first but it did not work unfortunately. I also found the merged issue regarding that I should be able to upgrade directly (in that case from 9.0.8 to 10.0.X). No idea, why it does not work though…


#4

Thank you Tom! I’ll do the upgrade tomorrow and let you guys know how it goes!


#5

Hey,

from what i understand / had read in the past this won’t work. You probably need to either upgrade from 8.2.11 directly to 10.0.10 or if you’re already at 9.0.8 you would first need to go to 9.0.11, afterwards to 9.1.8 and then finally to 10.0.10


#6

Hi Tom,
thanks for your reply. If you read my initial post you will see, that I am at 9.0.11 and can not update to any version beyond that…
Cheers,
Alex


#7

Hey,

seems there are some confusion about the versions (you had posted something about 9.0.8 previously). :confused:

But if you’re really on ownCloud 9.0.11 then the next step would be 9.1.8 followed by an update to 10.0.10.

If that doesn’t work (the step from 9.0.11 to 9.1.8) and you’re getting the message about “Exception: Updates between multiple major versions and downgrades are unsupported.” then could it be possible that your installation is indeed not at 9.0.11 as you’re expecting it?


#8

Hi Tom,

what I meant with the upgrade from 9.0.8 is that I found confirmation due to a merged piece of code which should allow a direct upgrade (skipping any 9.1.X version) from there.
I am at 9.0.11 but also tried coming from 9.0.8 and can not upgrade to any further version.

The version information I can look up in my owncloud directory definitely states 9.0.11 at the moment.- I do not expect anything I am just really really confused about this error as it does not let me upgrade any further to any of the versions I tried…

Cheers,
Alex


#9

Hey,

if your config.php and your admin GUI says that you’re at 9.0.11 and an upgrade to 9.1.8 isn’t possible due to this message then i think its probably the best to report such an issue to a bugtracker rather then to a user support forums.

AFAIK the bugtracker of ownCloud and the component (the server) is located here: https://github.com/owncloud/core/issues