Upgrade from 9.1.6 to 10.0.2 stalls at "updating dav"

9.1.x

#1

Steps to reproduce

  1. Upgrade Owncloud from 9.1.6 to 10.0.2
    2.After running the upgrade via command line "update schema" completes "update database" completed and it stalls at "updating ..... I let this sit for hours with no luck?
    3.

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:

Web server:

Database:

PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/...

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/...

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here


{"reqId":"jT8ZE0MERoYPochCKMZR","level":0,"time":"2017-09-22T01:38:06+00:00","remoteAddr":"","user":"--","app":"core","method":"--","url":"--","message":"starting upgrade from 9.1.6.2 to 10.0.2.1"}
{"reqId":"jT8ZE0MERoYPochCKMZR","level":3,"time":"2017-09-22T01:38:06+00:00","remoteAddr":"","user":"--","app":"PHP","method":"--","url":"--","message":"file_put_contents(\/srv\/www\/htdocs\/owncloud\/data\/.htaccess): failed to open stream: Permission denied at \/srv\/www\/htdocs\/owncloud\/lib\/private\/Setup.php#479"}


#### Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log
c) ...
`


#2

Hi,

are you following the instructions in the documentation on how to upgrade your ownCloud manually?

https://doc.owncloud.com/server/10.0/admin_manual/maintenance/manual_upgrade.html


#3

Hi Dimitry,

Yes I followed the steps exactly, I have done many upgrades in the past I have been using owncloud since version 6. This is really strange because it doesn't really throw an error is just sits there at "updating dav" . During this time the CPU utilization goes up to about 25%. Looking at the ownccloud.log doesn't really tell anything, is there potentially another place that I can look that would help narrow this down?

Thanks


#4

Just for a try: Did you tried to upgrade to 10.0.3 or are you stuck?


#5

I just noticed this error. Are you sure your permissions are right?

Also, you can try deactivating 3rd party apps before the upgrade.


#6

I would assume the perms are correct I ran the script that owncloud recommends for strong permission settings. Is there a command that disables all 3rd party apps?


#7

I don't think so :smiley: But it would be nice.

I think for example the calendar app is a 3rd party app. I wold try to disable that, and try the upgrade