Upgrade from 9 to 10.0.8 - poor performance


#1

I was running a version of owncloud 9 I wanted to upgrade to the latest 10 version

I have upgraded my server from Debian 8 to Debian 9.5, upgraded php to php7.2 Apache to 2.45 Redis setup for memcache.locking

When 1st page loaded it displayed message indicating it was dealing with data base. Left this running over night. Message still displayed in morning. Reloaded page. Would this have damaged the database?

Expected behaviour

after upgrading the performance is poor. Delays of 30 seconds connecting to server, 30 second delay in logging in delay of at least 30 seconds loading data into pages

I have not changed the apache2 configurration

owncloud config

<?php $CONFIG = array ( 'updatechecker' => false, 'instanceid' => 'oc6qyvaosocb', 'passwordsalt' => 'dI0SFs6ZaFijUXajS/dxQ3j//dVVGc', 'secret' => '8h96XGeKm949ySSWa0UCLkll9N3c3QDHZIrwmhEBFo+T/S7i', 'defaultapp' => 'calendar', 'trusted_domains' => array ( 0 => '***', 1 => '***', ), 'datadirectory' => '/ocdata/data', 'overwrite.cli.url' => '*', 'dbtype' => 'mysql', 'version' => '10.0.8.5', 'dbname' => 'owncloud', 'dbhost' => 'localhost', 'dbtableprefix' => 'oc_', 'dbuser' => '*', 'dbpassword' => '*', 'default_language' => 'en', 'logtimezone' => 'America/Regina', 'installed' => true, 'mail_smtpmode' => 'smtp', 'mail_smtphost' => 'mail.*.org', 'mail_from_address' => 'owncloud', 'mail_domain' => 'gdins.org', 'mail_smtpauthtype' => 'LOGIN', 'mail_smtpauth' => 1, 'mail_smtpname' => '*', 'mail_smtppassword' => '*', 'mail_smtpport' => '587', 'log_type' => 'owncloud', 'logfile' => '/ocdata/owncloud.log', 'loglevel' => 2, 'maintenance' => false, 'theme' => '', 'memcache.local' => '\\OC\\Memcache\\Redis', 'memcache.locking' => '\\OC\\Memcache\\Redis', 'redis' => array ( 'host' => 'localhost', 'port' => 6379, ), ); In case database performance was issue set /etc/myaql/my.cnf -- my.cnf --- innodb_buffer_pool_instances = 2 innodb_buffer_pool_size = 2G innodb_log_file_size = 128M query_cache_limit = 3M skip-name-resolve = 1 key_buffer = 32M thread_cache_size = 50 table_open_cache = 2048 max_connections = 500 tmp_table_size = 32M ### Actual behaviour significant delay accessing site and loading pages ### Server configuration **Operating system**: Debian 9.5 **Web server:** Apache 2.4.25 **Database:** MySql **PHP version:** 7.2 **ownCloud version:** (see ownCloud admin page) 10.0.0.8 **Updated from an older ownCloud or fresh install:** update from 9 to 10 **Where did you install ownCloud from:** owncloud.org **Signing status (ownCloud 9.0 and above):** **The content of config/config.php:** { "basic": { "license key": "***REMOVED SENSITIVE VALUE***", "date": "Fri, 20 Jul 2018 17:31:54 +0000", "ownCloud version": "10.0.8.5", "ownCloud version string": "10.0.8", "ownCloud edition": "Community", "server OS": "Linux", "server OS version": "Linux calowncloud 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2+deb8u3 (2016-07-02) x86_64", "server SAPI": "apache2handler", "webserver version": "Apache\/2.4.25 (Debian)", "hostname": "*.org", "user count": 41, "user directories": 41, "logged-in user": "*r" }, "config": { "updatechecker": false, "instanceid": "*", "passwordsalt": "***REMOVED SENSITIVE VALUE***", "secret": "***REMOVED SENSITIVE VALUE***", "defaultapp": "calendar", "trusted_domains": [ "*", "*" ], "datadirectory": "\/ocdata\/data", "overwrite.cli.url": "https:\/\/connect.gdins.org", "dbtype": "mysql", "version": "10.0.8.5", "dbname": "owncloud", "dbhost": "localhost", "dbtableprefix": "oc_", "dbuser": "***REMOVED SENSITIVE VALUE***", "dbpassword": "***REMOVED SENSITIVE VALUE***", "default_language": "en", "logtimezone": "America\/Regina", "installed": true, "mail_smtpmode": "smtp", "mail_smtphost": "***REMOVED SENSITIVE VALUE***", "mail_from_address": "***REMOVED SENSITIVE VALUE***", "mail_domain": "***REMOVED SENSITIVE VALUE***", "mail_smtpauthtype": "LOGIN", "mail_smtpauth": 1, "mail_smtpname": "***REMOVED SENSITIVE VALUE***", "mail_smtppassword": "***REMOVED SENSITIVE VALUE***", "mail_smtpport": "587", "log_type": "owncloud", "logfile": "\/ocdata\/owncloud.log", "loglevel": 2, "maintenance": false, "theme": "", "memcache.local": "\\OC\\Memcache\\Redis", "memcache.locking": "\\OC\\Memcache\\Redis", "redis": { "host": "localhost", "port": 6379 } }, "integritychecker": { "passing": false, "enabled": true, "result": { "core": { "INVALID_HASH": { "lib\/private\/legacy\/response.php": { "expected": "98fba17e901d3496f1bad7ab0c07fa210baccb004045d017ffb5c8887e2996e20f7a396b17c3305c536891ef98a641a6567d22e5ae30e0248d4151cc18eace67", "current": "e7ddd9e1351a610fd315df7403c693544ac00e3265307483608fe96c933bb76cfa65cdf9fa549584d8945b7e0abc74e07f895115bfc8a09e6050fd0212ff1d8e" } }, "EXTRA_FILE": { Many extra files ,,,, **List of activated apps:** Enabled: - activity: 2.3.7 - calendar: 1.5.7 - comments: 0.3.0 - configreport: 0.1.1 - contacts: 1.5.4 - customgroups: 0.3.6 - dav: 0.3.2 - federatedfilesharing: 0.3.1 - federation: 0.1.0 - files: 1.5.1 - files_clipboard: 0.7.1 - files_external: 0.7.1 - files_pdfviewer: 0.9.0 - files_sharing: 0.10.1 - files_texteditor: 2.2.1 - files_trashbin: 0.9.1 - files_versions: 1.3.0 - files_videoplayer: 0.9.8 - firstrunwizard: 1.1 - gallery: 16.1.0 - groupalert: 1.0.5 - impersonate: 0.2.0 - market: 0.2.4 - notes: 2.0.4 - notifications: 0.3.3 - provisioning_api: 0.5.0 - systemtags: 0.3.0 - tasks: 0.9.6 - templateeditor: 0.3 - updatenotification: 0.2.1 ``` **Are you using external storage, if yes which one:** local/smb/sftp/... no **Are you using encryption:** yes/no no **Are you using an external user-backend, if yes which one:** LDAP/ActiveDirectory/Webdav/... no ### Client configuration **Browser:** chrome **Operating system:** windows 10 ### Logs #### Web server error log ``` Insert your webserver log here ``` #### ownCloud log (data/owncloud.log) ``` Insert your ownCloud log here {"reqId":"VyjI5cc3DPadfqdzSL92","level":3,"time":"2018-07-20T11:41:04-06:00","remoteAddr":"198.169.113.108","user":"--","app":"PHP","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"ini_set(): A session is active. You cannot change the session module's ini settings at this time at \/var\/www\/owncloud\/lib\/base.php#596"} {"reqId":"39dc8XMYq70j8Z0lpedK","level":3,"time":"2018-07-20T11:41:12-06:00","remoteAddr":"204.83.241.101","user":"--","app":"PHP","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"ini_set(): A session is active. You cannot change the session module's ini settings at this time at \/var\/www\/owncloud\/lib\/base.php#596"} {"reqId":"cuuUtr7UkztRG1KCAD01","level":3,"time":"2018-07-20T11:41:15-06:00","remoteAddr":"204.83.241.101","user":"--","app":"PHP","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"ini_set(): A session is active. You cannot change the session module's ini settings at this time at \/var\/www\/owncloud\/lib\/base.php#596"} {"reqId":"Rcjx6ULQHl6lwTJ4VgFl","level":3,"time":"2018-07-20T11:41:15-06:00","remoteAddr":"198.169.113.108","user":"--","app":"PHP","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"ini_set(): A session is active. You cannot change the session module's ini settings at this time at \/var\/www\/owncloud\/lib\/base.php#596"} {"reqId":"DMZl8EQJRwilH39gtuVC","level":3,"time":"2018-07-20T11:41:35-06:00","remoteAddr":"198.169.113.108","user":"--","app":"PHP","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"ini_set(): A session is active. You cannot change the session module's ini settings at this time at \/var\/www\/owncloud\/lib\/base.php#596"} {"reqId":"3jEAFkIsTWgYueqqgVcH","level":3,"time":"2018-07-20T11:41:42-06:00","remoteAddr":"204.83.241.101","user":"--","app":"PHP","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"ini_set(): A session is active. You cannot change the session module's ini settings at this time at \/var\/www\/owncloud\/lib\/base.php#596"} {"reqId":"52OIl1rD7yYoHCGwDNVx","level":3,"time":"2018-07-20T11:41:45-06:00","remoteAddr":"204.83.241.101","user":"--","app":"PHP","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"ini_set(): A session is active. You cannot change the session module's ini settings at this time at \/var\/www\/owncloud\/lib\/base.php#596"} {"reqId":"uwTFl95DL9VTbMkHhrem","level":3,"time":"2018-07-20T11:41:45-06:00","remoteAddr":"198.169.113.108","user":"--","app":"PHP","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"ini_set(): A session is active. You cannot change the session module's ini settings at this time at \/var\/www\/owncloud\/lib\/base.php#596"} {"reqId":"bs52t4zlmAZB1nlgtARo","level":3,"time":"2018-07-20T11:42:05-06:00","remoteAddr":"198.169.113.108","user":"--","app":"PHP","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"ini_set(): A session is active. You cannot change the session module's ini settings at this time at \/var\/www\/owncloud\/lib\/base.php#596"} {"reqId":"Sy9aEBzxKzaVdL56nKhg","level":3,"time":"2018-07-20T11:42:12-06:00","remoteAddr":"204.83.241.101","user":"--","app":"PHP","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"ini_set(): A session is active. You cannot change the session module's ini settings at this time at \/var\/www\/owncloud\/lib\/base.php#596"}

#2

Hey, from what i know ownCloud 10.0.8 isn’t compatible (or at least not fully) with PHP 7.2 which could explain the logs in the logfile and maybe the login issues as well.