Upgrade Issues to OC on CentOS7

I am currently running CentOS7 and upgraded OC from 10.0.X (don’t remember exact version) to I have performed these “manual upgrades” multiple times in the past with no issues. However, this time was different. Everything seemed to go ok. Even the sudo -u apache php occ upgrade finished without errors. However, when I go to the main page, I get a message “File not found The specified document has not been found on the server.[You can click here to return to]”. I did not change any of my apache settings or PHP settings. The one thing I did do that I normally don’t (in following the upgrade guide) is ran the pre-requisites check.


Which could have possibly upgraded my PHP version to 7.2 (not sure where it was prior to the upgrade).

I have checked the following log files:

  • /var/www/html/owncloud/data/owncloud.log
  • /var/log/httpd/error_log
  • /var/log/httpd/ssl_error_log

None of these files appear to have anything relevant to my situation or missing files.

I have also tried turning maintenance mode back on: sudo -u apache php occ maintenance:mode --on and instead of the maintenance screen, I still get the file not found screen.

So I am not sure if I am missing a file from the upgrade, or there is something going on with PHP itself.

If there are any suggestions, I would greatly appreciate anything I can get.

In my Google searching, all I can come up with that is even close refers to a libapache2-mod-php5 module. But my understanding is that it does not apply to CentOS.

Let me know if I can provide any further information. Thanks in advance for your help.

I ended up resolving this issue. The upgrade process placed a .htaccess file in there where I did not have one previously. (Ended up comparing files from my backup). However, I feel like the file should be there (especially if the upgrade process put it there), but I am not familiar enough with the .htaccess to know what needs to change. But it is operational for tonight, time to get some ZZZZZ’s.