Upgrade problem 10.10.0 to 10.12.0

I tried to upgrade my community version from 10.10.0 to 10.12.0.
Therefore I did teh manual steps as described in the docu, but the setting:
sudo find -L /var/www/owncloud
( -path ./data -o -path ./config ) -prune -o
-type d -print0 | sudo xargs -0 chown root:www-data

doesn’t change all folder rights; some are still “nobody” (except config und data); so I also couldn’t run the occ upgrade process with the www-data user.

Does anybody have an idea why the permissions are not set correct?
And another question: For the upgrade I have to change the version in the config.php file from to 10.12.0. Is this correct?

Thanks for your help

According to the docs:

Set correct ownership

Set the ownership for all files and folders to root:www-data except the config and data directory:

sudo find -L /var/www/owncloud \

This is expected, your supposed to run the next step in order to finalise:

Set the ownership for all files and folders to www-data:www-data for the config, data and apps directories. Note that it is not mandatory to set the ownership of the data/ directory as it should already have the correct ownership and it can take a while to finish, depending on the size:

sudo chown -R www-data:www-data /var/www/owncloud/config
sudo chown -R www-data:www-data /var/www/owncloud/data
sudo chown -R www-data:www-data /var/www/owncloud/apps

And then continue with the mode, before running the occ upgrade command.

Hi…thanks for your answer. I tried now first to upgrade to 10.11.0 and downloaded therefore the 10.11.0 tar file; the upgrade worked now, hoewever the config.php file and also the owncloud portal shows me, taht I have the version 10.12.0 installed.

How is this possible? I extracted the 10.11.0 file and ran the upgrade process.

Best regards

Not sure, perhaps you actually downloaded 10.12. and you only thought you downloaded 10.11?
It’s close to impossible for me to tell from afar.

yes, you are right; 10.12, 10.11 und 10.10 have all the same hash ; so you always download the latest version; thanks for your help.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.