upgrading owncloud 8.2.7 to 9.0.4 (or 9.0.1) I get the following failure:

Doctrine\DBAL\Exception\DriverException: An exception occurred while executing 'CREATE TABLE oc_addressbooks (id BIGINT UNSIGNED AUTO_INCREMENT NOT NULL, principaluri VARCHAR(255) DEFAULT NULL, displayname VARCHAR(255) DEFAULT NULL, uri VARCHAR(255) DEFAULT NULL, description VARCHAR(255) DEFAULT NULL, synctoken INT UNSIGNED DEFAULT 1 NOT NULL, UNIQUE INDEX addressbook_index (principaluri, uri), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8 COLLATE utf8_bin ENGINE = InnoDB': SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 1000 bytes

How can I solve that problem?
Thanks Peter


if you crosspost issues here and at the bugtracker please always link them together to avoid cross-support. The specific issue was also alrady reported at the bugtracker here:

I'm facing the same issue (latest ver 9.1.4).
Any solution?


the linked issue above contains all needed info about this issue:

1 . Some work needs to be done by the ownCloud developers


2 . You need a InnoDB database type (which is mandatory for oC) instead of MyISAM.

In my case it's the second option.
Do you have some guide on how properly set up InnoDB database type in MySQL?

I think you will find quite a lot of info about the conversion from MyISAM to InnoDB on the net. Just had a few seconds search and stumbled over these:


1 Like