Upgrade to 10.5 Forcing Enterprise?

While attempting to update to Onwcloud Version 10.5 using the manual installation with the tarball file downloaded from here:

The upgrade was successful but It was giving me enterpirse licensing errors afterwords. I do not have an enterprise license nor do I want one.

I tried both the Complete and Minimal tarball download files and both gave me the same enterprise warnings.

Can I not update to 10.5 without having Enterprise forced on me?

Server configuration

Ubuntu 18.03:

**Web server:Apache


**PHP version:PHP 7

*ownCloud version: 10.4.1 (stable) *

Updated from an older ownCloud or fresh install: Updated

**Where did you install ownCloud from:Linux Packages

Login as admin user into your ownCloud and access 

No errors have been found.

Please, show the list of enabled apps you have.
There is a known problem with the richdouments app that will be eventually solved (Collabora Online on ownloud 10.5)


Apps I have installed:
Admin Config Report
Deleted files
Provisioning API
Share Files
Update notification
Collaborative tags
External Sites
First run wizard
External Storage: FTP
Text Editor
PDF Viewer
Files clipboard
External Storage: Dropbox
Mail Template Editor
Brute-Force Protection
Media Viewer

1 Like

Go to the command-line and run occ app:list to know what apps are enabled and disabled. As far as I know, only the richdocuments app could trigger this behaviour.


Do not have that one installed or enabled:


  • activity: 2.5.4
  • afterlogic: 1.2.2
  • brute_force_protection: 1.0.1
  • calendar: 1.6.4
  • comments: 0.3.0
  • configreport: 0.2.0
  • dav: 0.5.0
  • external: 1.4.0
  • federatedfilesharing: 0.5.0
  • federation: 0.1.0
  • files: 1.5.2
  • files_clipboard: 1.0.2
  • files_external: 0.7.1
  • files_external_dropbox: 1.2.0
  • files_external_ftp: 0.2.1
  • files_mediaviewer: 1.0.3
  • files_pdfviewer: 0.11.2
  • files_sharing: 0.12.0
  • files_texteditor: 2.3.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • firstrunwizard: 1.2.0
  • gallery: 16.1.1
  • impersonate: 0.5.0
  • market: 0.5.1
  • notes: 2.0.6
  • notifications: 0.5.0
  • provisioning_api: 0.5.0
  • qownnotesapi: 19.1.0
  • systemtags: 0.3.0
  • tasks: 0.9.7
  • templateeditor: 0.4.0
  • updatenotification: 0.2.1
  • encryption
  • user_external

Maye we’re going the wrong way.

Could you show an screenshot of the error?


This is the login screen I get after upgrading:

login screen

This is the error I get at the top of the screen after logging in:

And this is the version number:

Definitely your installation had a license at some point, and that license has expired. That’s why that message appears.

I don’t think ownCloud provides an easy way to remove the license, so I’d suggest to ignore the message.
If it bothers you, you’ll have to remove the license manually. There are 2 location to look for: the config.php file (in the “license-key” key) and the DB (oc_appconfig table -> enterprise_key appid -> license-key key)

1 Like

Strange. I believe I did try the trial for enterprise a couple of years ago. I’ve never had this issue for any upgrades since then. I’m not sure why it is an issue now. I don’t have any license-key entries in my config.php but there are some references in my DB. I’m not sure how to get rid of them or which ones to get rid of.

Ok, Removing the 3 or 4 tables in the DB that had reference to Enterprise appears to have solved my problem. I was able to upgrade and no longer get the errors. Thanks for your help!

1 Like