Upgradepath 8.1.1.3


#1

Hello,

i am on the verge to upgrade oc 8.1.1.3 to 10.0.10.
centos7 - 1503
oc 8.1.1.3
ssh access
about 200 users
mariadb
php 5.4

i do have ssh access and sudo rights. The goal is to upgrade oc on 10.0.10 and also
upgrade centos (from 1503 to 1810)

so i worked the docs and i am still unsure about the best way.

first question ? is it possible to start the graphical upgradeprocess from remote ?
8.1 - 8.2 -9.0 -9-1-10.0 would be the way.

is the migrationprocess possible without checking migration-test ? i know it is possible on cli with occ…but also in graphical app ?
The plan is to upgrade to 10.0.10. Then install php72 from remi repo and update centos7 to 1810.

I honestly dont know how long does it will take. Would it be wiser to install 10.0.10 without the upgradeprocess ? mv the old oc-folder and install the new one ? Any hints ?

questions over questions…

greetings gunta

Steps to reproduce

Expected behaviour

Tell us what should happen
i want to do an upgrade from oc 8.1 to 10.0.10

Actual behaviour

Tell us what happens instead
nothing meanwhile. i am still considering the best way to so this

Server configuration

Operating system:
centos7 (1503)

Web server:
apache 2.4

Database:

PHP version:
5.4.16

ownCloud version: (see ownCloud admin page)
8.1.

Updated from an older ownCloud or fresh install:
was a fresh install in 2015

Where did you install ownCloud from:
opensuse.repo.

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

<?php $CONFIG = array ( 'instanceid' => 'xxxxxxx', 'passwordsalt' => 'xxxxxxxxxxxxxxxxxx', 'secret' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx', 'trusted_domains' => array ( 0 => 'example.com', ), 'datadirectory' => '/var/ocdata', 'overwrite.cli.url' => 'https://example.com', 'dbtype' => 'mysql', 'version' => '8.1.1.3', 'dbname' => 'owncloud', 'dbhost' => 'MySQL1iR.example.com', 'dbtableprefix' => 'oc_', 'dbuser' => 'xxxx', 'dbpassword' => 'xxxxxxx', 'logtimezone' => 'UTC', 'installed' => true, 'theme' => 'xx', 'maintenance' => false, 'user_backends' => array ( 0 => array ( 'class' => 'OC_User_IMAP', 'arguments' => array ( 0 => array ( 'class' => 'OC_User_IMAP', 'arguments' => array ( 0 => '{mail.xxxxxxxx:993/imap/ssl}', ), ), ), 'mail_smtpmode' => 'smtp', 'mail_from_address' => 'drive', 'mail_domain' => 'example.com', ``` Log in to the web-UI with an administrator account and click on 'admin' -> 'Generate Config Report' -> 'Download ownCloud config report' This report includes the config.php settings, the list of activated apps and other details in a well sanitized form. or If you have access to your command line run e.g.: sudo -u www-data php occ config:list system from within your ownCloud installation folder *ATTENTION:* Do not post your config.php file in public as is. Please use one of the above methods whenever possible. Both, the generated reports from the web-ui and from occ config:list consistently remove sensitive data. You still may want to review the report before sending. If done manually then it is critical for your own privacy to dilligently remove *all* host names, passwords, usernames, salts and other credentials before posting. You should assume that attackers find such information and will use them against your systems. ``` **List of activated apps:** ``` If you have access to your command line run e.g.: sudo -u www-data php occ app:list from within your ownCloud installation folder. ```Enabled: - activity: 2.0.1 - files: 1.1.10 - files_pdfviewer: 0.7 - files_sharing: 0.6.2 - files_texteditor: 0.4 - files_trashbin: 0.6.3 - files_videoviewer: 0.1.3 - firstrunwizard: 1.1 - gallery: 0.6.0 - user_external: 0.4 Disabled: - encryption - external - files_external - files_locking - files_versions - galleryplus - provisioning_api - templateeditor - user_ldap - user_webdavauth **Are you using external storage, if yes which one:** local/smb/sftp/... /var/ocdata **Are you using encryption:** yes/no Apache with ssl owncloud no **Are you using an external user-backend, if yes which one:** LDAP/ActiveDirectory/Webdav/... AD #### LDAP configuration (delete this part if not used) ``` With access to your command line run e.g.: sudo -u www-data php occ ldap:show-config from within your ownCloud installation folder Without access to your command line download the data/owncloud.db to your local computer or access your SQL server remotely and run the select query: SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap'; Eventually replace sensitive data as the name/IP-address of your LDAP server or groups. ``` ### Client configuration **Browser:** chrome **Operating system:** linux mint 18.3 ### Logs #### Web server error log ``` Insert your webserver log here ``` #### ownCloud log (data/owncloud.log) ``` Insert your ownCloud log here ``` #### Browser log ``` Insert your browser log here, this could for example include: a) The javascript console log b) The network log c) ... ```

#2

Hey,

from what i have read in the past you would need to upgrade from 8.1.1 to 8.1.12, afterwards to 8.2.11 and then you could directly jump to 10.0.10/the upcoming 10.1.0.


#3

thanks tom,

do you know by any chance, if this upgrade is in the graphical mode possible from remote ?


#4

Hey,

from what i know / have read in the past the recommendation is to always use the occ command line tool to do the upgrade. This seems to be the most reliable way which i’m personally using as well.


#5

okay…thanks

greeting gunter


#6

so now im stuck.

difd the updatepath…
8.1.3
8.1.12
8.2.11
9.0.11
9.1.8
10.0.10
and by the last upgrade it hangs on the app “dav”

cant deactivate ist…nor can i access the webgui.
sudo -u apache php occ app:disable dav

cant disable dav…was the errormessage.

i removed this app from the app folder…no success. > upgrade failed was the message.

any ideas how i can deactivate the dav app ?

lg. gunter


#7

Hey,

could you explain the reason for using a different upgrade path then the previously recommended one i had posted?

Personally i would revert to the previous backup and then try the one i had suggested which is (as far as i have read so far) the recommended one.

I had also read some suggestions in the past that we need to make sure that the old files of the previous ownCloud installation (on each upgrade step) needs to be deleted while keeping the config/config.php file and the /data folder.


#8

because he suggested this path…

btw… i always copied the new owncloud folder in the path and then copied the config.php and data folder from the previous version in this new owncloud folder.
this worked till 9.1.8. anfd from 9.1.8 to 10.0.10 not. with the new remi php 72 packages included. now i hang with the update. and you cant disable the dav app…so it stands in the documentation


#9

i do have 10.0.10.4 installed but no access to gui. so i read that dav is not in the supported apps in 10.0.10 ??
https://doc.owncloud.org/server/10.0/admin_manual/installation/apps_supported.html


#10

Hey,

unfortunately i don’t know who “he” is :slightly_frowning_face:. Currently i’m the only poster in this thread and have only suggested to update from 8.1.1 to 8.1.12, then to 8.2.11 and afterwards to 10.0.10.

From what i know “dav” is essential/mandatory app in ownCloud which are always included and which can’t be disabled.

Could it be possible by any chance that you have also copied over the “apps” folder from the older installation?


#11

still awake ? it will be a long night…sigh

so “he” was the suggestion in the gui…the banner on the top. so did this per commandline.

meanwhile i erased the install and put the community source in…
http://download.owncloud.org/download/repositories/stable/CentOS_7/ce:stable.repo

and installed owncloud. put the config file and the data folder in there…run the upgrade and got also stuck by dav.

and no…no old apps folder was copied into the new one…


#12

is it possible that i need webdav from the marketplace ?
in the description of the dav app it is named webdav ?


#13

Hey,

i don’t think that you can install/update this app separately as it is a core component included in ownCloud (thus the “can’t disable dav”).

Personally i would still suggest to try the different upgrade path after reverting to your previous backup but maybe some other readers have any additional/other suggestion.


#14

so first things first…thanks for your time and input @tom42.

meanwhile oc10 is running.

what did i do.
after my first upgradepath the dav app didnt upgrade in the last process > 9.1.8 > 10.0.10. i tried this of course on cli.
after the install of 9.1.8 i switched to “remi php72” repo and rebootet the machine also. updated
from 1503 to 1810 > centos 7.6
then i reverted to 8.2.12. and tried from there to 10.0.10. also no luck with dav app.
so i skipped manual installation and downloaded from owncloud repo >

wget http://download.owncloud.org/download/repositories/stable/CentOS_7/ce:stable.repo

and installed it with yum install owncloud

the upgradeprocess was at last successful. but i had to wait nearly 50 minutes, till the dav app was upgraded. i honestly dont know, if this would also be successful with the manual installation.

i got an successful update message at least.

in the end the imap authentication was a little borked, because in the upgradeprocess the users in the database had false values > db_user instead of names. so i had only root access. switched the values of the users in database and all set. i also installed redis and apcu in accoordance to the owncloud docs…no errors meanwhile.

in retrospect took me the dav app some hours out of my life. and i dont know why the upgradeprocess took only there so long.

thats it

greets gunta