Upload file from Android client > 512MB


#1

Heloo, please help.

Android Client OC version 2.6.0

1.
server ownCloud 9.1.5 (stable) + Centos7 + php-5.4.16-43.el7_4.x86_64 + httpd-2.4.6-67.el7.centos.6.x86_64
Client sent file 546MB - OK
88.100.20.46 - admin [20/Mar/2018:22:09:40 +0100] "PUT /dekorace/remote.php/webdav/VID_20180318_185115.mp4-chunking-4528-562-560 HTTP/1.1" 201 - "-" "Mozilla/5.0 (Android) ownCloud-android/2.6.0"
88.100.20.46 - admin [20/Mar/2018:22:09:41 +0100] "PUT /dekorace/remote.php/webdav/VID_20180318_185115.mp4-chunking-4528-562-561 HTTP/1.1" 201 - "-" "Mozilla/5.0 (Android) ownCloud-android/2.6.0"

2.
version ownCloud 10.0.7.2 + FedoraCore 27 + php-7.1.15-1.fc27.x86_64 + httpd-2.4.29-1.fc27.x86_64
Client sent file 546MB - FAIL
10.27.24.1 - - [20/Mar/2018:00:07:38 +0100] "PUT /itnaklic/remote.php/webdav/VID_20180318_185115%20(2).mp4-chunking-4389-562-560 HTTP/1.1" 201 -
10.27.24.1 - - [20/Mar/2018:00:07:39 +0100] "PUT /itnaklic/remote.php/webdav/VID_20180318_185115%20(2).mp4-chunking-4389-562-561 HTTP/1.1" 504 247

owncloud.log in error time empty :frowning:

Nightmare :frowning:

Thanks for idea

Havrla


#2

Hi,

did you already checked this:

https://doc.owncloud.com/server/10.0/admin_manual/configuration/files/big_file_upload_configuration.html?highlight=big%20files


#3

Heloo,

Upload 700BM via WEBpages OK:
10.27.24.1 - - [21/Mar/2018:13:38:31 +0100] "PUT
/itnaklic/remote.php/dav/uploads/zdenek/web-file-upload-fc33ba472e5c0878818499fee5ea3b39-1521635696170/713031680
HTTP/1.1" 201 -
10.27.24.1 - - [21/Mar/2018:13:38:33 +0100] "PUT
/itnaklic/remote.php/dav/uploads/zdenek/web-file-upload-fc33ba472e5c0878818499fee5ea3b39-1521635696170/723517440
HTTP/1.1" 201 -
10.27.24.1 - - [21/Mar/2018:13:38:39 +0100] "MOVE
/itnaklic/remote.php/dav/uploads/zdenek/web-file-upload-fc33ba472e5c0878818499fee5ea3b39-1521635696170/.file
HTTP/1.1" 201 -

Upload 1,6G via android client KO:
80.188.253.1 - - [21/Mar/2018:16:36:31 +0100] "PUT
/itnaklic/remote.php/webdav/VID_20180318_190450.mp4-chunking-8555-1654-1651
HTTP/1.1" 201 -
80.188.253.1 - - [21/Mar/2018:16:36:33 +0100] "PUT
/itnaklic/remote.php/webdav/VID_20180318_190450.mp4-chunking-8555-1654-1652
HTTP/1.1" 201 -
80.188.253.1 - - [21/Mar/2018:16:36:35 +0100] "PUT
/itnaklic/remote.php/webdav/VID_20180318_190450.mp4-chunking-8555-1654-1653
HTTP/1.1" 504 247

Problem with "before last" chunk.
Android client - webdav, KO
WEBpages - dav , OK

Thanks for idea.

Havrla


Verify manual big files, OK:
[root@cl-itnk-clouditnaklic ~]# grep "upload_max_filesize\|post_max_size" /etc/php.ini
post_max_size = 16400M
upload_max_filesize = 16G
[root@cl-itnk-clouditnaklic ~]# grep "upload_max_filesize\|post_max_size" /var/www/html/itnaklic/.htaccess
php_value upload_max_filesize 16G
php_value post_max_size 16G
php_value upload_max_filesize 5130M
php_value post_max_size 16G
[root@cl-itnk-clouditnaklic ~]# grep "upload_max_filesize\|post_max_size" /var/www/html/itnaklic/.user.ini
upload_max_filesize=16G
post_max_size=16G
[root@cl-itnk-clouditnaklic ~]# grep "max_input_time\|max_execution_time" /etc/php.ini
; max_input_time
max_execution_time = 3600
max_input_time = 3600
[root@cl-itnk-clouditnaklic ~]# grep "max_input_time\|max_execution_time" /var/www/html/itnaklic/.htaccess
[root@cl-itnk-clouditnaklic ~]# grep "max_input_time\|max_execution_time" /var/www/html/itnaklic/.user.ini
[root@cl-itnk-clouditnaklic ~]# grep "LimitRequestBody" /etc/httpd/conf/httpd.conf
[root@cl-itnk-clouditnaklic ~]# grep "LimitRequestBody" /etc/httpd/conf.d/ssl.conf
[root@cl-itnk-clouditnaklic ~]# grep -i "LimitRequestBody" /etc/httpd/conf/httpd.conf
[root@cl-itnk-clouditnaklic ~]# grep -i "LimitRequestBody" /etc/httpd/conf.d/ssl.conf
[root@cl-itnk-clouditnaklic ~]# grep -i "SSLRenegBufferSize" /etc/httpd/conf/httpd.conf
[root@cl-itnk-clouditnaklic ~]# grep -i "SSLRenegBufferSize" /etc/httpd/conf.d/ssl.conf
[root@cl-itnk-clouditnaklic ~]# grep -i "FcgidMaxRequestInMem" /etc/httpd/conf.d/ssl.conf
[root@cl-itnk-clouditnaklic ~]# grep -i "FcgidMaxRequestInMem" /etc/httpd/conf/httpd.conf
[root@cl-itnk-clouditnaklic ~]# grep -i "FcgidMaxRequestLen" /etc/httpd/conf.d/ssl.conf
[root@cl-itnk-clouditnaklic ~]# grep -i "FcgidMaxRequestLen" /etc/httpd/conf/httpd.conf
[root@cl-itnk-clouditnaklic ~]#
[root@cl-itnk-clouditnaklic ~]# grep output_buffering /etc/php.ini
; output_buffering
output_buffering = Off
; performance, enable output_buffering in addition.
[root@cl-itnk-clouditnaklic ~]# grep output_buffering /var/www/html/itnaklic/.htaccess
php_value output_buffering 0
php_value output_buffering 0
[root@cl-itnk-clouditnaklic ~]# grep output_buffering /var/www/html/itnaklic/.user.ini
output_buffering=0
[root@cl-itnk-clouditnaklic ~]#
Limits:
Server KO:
[root@cl-itnk-clouditnaklic ~]# cat /proc/948/limits
Limit Soft Limit Hard Limit Units
Max cpu time unlimited unlimited seconds
Max file size unlimited unlimited bytes
Max data size unlimited unlimited bytes
Max stack size 8388608 unlimited bytes
Max core file size unlimited unlimited bytes
Max resident set unlimited unlimited bytes
Max processes 15681 15681 processes
Max open files 1024 4096 files
Max locked memory 65536 65536 bytes
Max address space unlimited unlimited bytes
Max file locks unlimited unlimited locks
Max pending signals 15681 15681 signals
Max msgqueue size 819200 819200 bytes
Max nice priority 0 0
Max realtime priority 0 0
Max realtime timeout unlimited unlimited us
[root@cl-itnk-clouditnaklic ~]#

Server OK:
[root@tonda ~]# cat /proc/20735/limits
Limit Soft Limit Hard Limit Units
Max cpu time unlimited unlimited seconds
Max file size unlimited unlimited bytes
Max data size unlimited unlimited bytes
Max stack size 8388608 unlimited bytes
Max core file size 0 unlimited bytes
Max resident set unlimited unlimited bytes
Max processes 159781 159781 processes
Max open files 1024 4096 files
Max locked memory 65536 65536 bytes
Max address space unlimited unlimited bytes
Max file locks unlimited unlimited locks
Max pending signals 159781 159781 signals
Max msgqueue size 819200 819200 bytes
Max nice priority 0 0
Max realtime priority 0
Max realtime timeout unlimited unlimited
us
[root@tonda ~]#


#4

So... does it work?

Could you write a summery? :slight_smile:


#5

Heloo

Not work upload big file.

Client android owncloud,
Server ownCloud 9.1.5 (stable) + Centos7 + php-5.4.16-43.el7_4.x86_64 + httpd-2.4.6-67.el7.centos.6.x86_64 - Work upload big file via wepage and android client
Server ownCloud 10.0.7.2 + FedoraCore 27 + php-7.1.15-1.fc27.x86_64 + httpd-2.4.29-1.fc27.x86_64 - Work upload big file via webpage, not work upload big file via android client.

Problem:
560MB file (apache access log):
10.27.24.1 - - [20/Mar/2018:00:07:38 +0100] "PUT /itnaklic/remote.php/webdav/VID_20180318_185115%20(2).mp4-chunking-4389-562-560 HTTP/1.1" 201 -
10.27.24.1 - - [20/Mar/2018:00:07:39 +0100] "PUT /itnaklic/remote.php/webdav/VID_20180318_185115%20(2).mp4-chunking-4389-562-561 HTTP/1.1" 504 247
1,6TB file (apache access log)
80.188.253.1 - - [21/Mar/2018:16:36:33 +0100] "PUT
/itnaklic/remote.php/webdav/VID_20180318_190450.mp4-chunking-8555-1654-1652
HTTP/1.1" 201 -
80.188.253.1 - - [21/Mar/2018:16:36:35 +0100] "PUT
/itnaklic/remote.php/webdav/VID_20180318_190450.mp4-chunking-8555-1654-1653
HTTP/1.1" 504 247

Big file is chunking. Penultimate chunk = server respond 504 error

HINT:
Android client use in URI /webdav/
Webpage use in URI /dav/

Thanks for idea

Havrla


#6

Heloo
problem solved - OS reinstall to CentOS7

Havrla