Upload of files larger then 64K fails with bad gateway error


#1

Steps to reproduce

1.Start Google Chrome, open OC webportal
2.Drag a file +64K in the file area and wait for it to get uploaded.
3.After a long time error comes up bad gateway error 502
4.file is not uploaded

Expected behaviour

Tell us what should happen
The file should be uploaded. Up to last week it had always worked.

Actual behaviour

Tell us what happens instead
When uploading a file a black progress bar appears. It fills to the end and then just says there for several minutes. Then a orange bar appears at the top of the window saying bad gateway error 502.

Server configuration

Operating system:
Linux

Web server:
Apache
Database:
Mysql
PHP version:

ownCloud version: (see ownCloud admin page)
9.0
Updated from an older ownCloud or fresh install:
Virtual machine downloaded from owncloud site
Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder
Don't know installation folder.ls 
*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…
No
Are you using encryption: yes/no
No
Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…
No

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:
Chrome
Operating system:
Windows 10

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

Hey,

maybe the following below is valid here as well?


#3

Good morning,

Thanks for the respons. I have been going over this page too. Problem is that I found more then one entry so I changed all of them to “16G”. I am not familliar with linux so it’s not easy to find out witch config files are beeing used and witch not.
Curious thing is that the problem suddenly occured last week without anyone changing something to the system. before that it all worked perfect.
Kind regards.
Wim A.


#4

You should consider upgrading to 10.0.10 as oC 9.0 is not longer supported.


#5

Good morning Dmitry,
I will do that. Hopefully this will solve my problem.

Regards
Wim A.


#6

Hello dmitry,
I have upgraded as you suggested but that didn’t solve the problem. After more troubleshooting I found out that the issue comes from our proxy server that forwards all requests to the owncloud server. On the proxy is a AVG webscanner active that for some reason blocks access to files. I have disabled the scanner and now everything works again.

Many thanks for your kind respons!
Regards.
Wim A.