Upload problem for files >1MB via the web interface (expected file size ... got ...)


#1

Hi,
I installed ownCloud on a shared server hosted by Namecheap. Everything seems to work fine except the upload. If I upload a file bigger than about 1MB, the progress bar moves until the end and then I get the message e.g. "expected file size 1292173 got 1048120.
I couldn't find anything about this problem searching with Google.
Thanks


#2

Hi,

have a look at our docs:

https://doc.owncloud.com/server/10.0/admin_manual/configuration/files/big_file_upload_configuration.html?highlight=big%20files#configuring-your-web-server


#3

Thanks for the quick reply - I will check it out


#4

The link is about "Uploading big files >512MB". But I cannot even upload a 2MB file.

I increased
upload_max_fileesize
post_max_size
php_value max_input_time
php_value max_execution_time

...via php.ini, but it didn't help


#5

have you tried contacting the support at "Namecheap"?

If you have installed owncloud correctly you should not have any problems.

You could search the owncloud log for hints. You can find it in Admin - Settings - general.


#6

I did the following search here:

https://central.owncloud.org/search?q=expected%20filesize
https://doc.owncloud.org/server/latest/admin_manual/search.html?q=expected+filesize

and stumbled over the following resources which could help:

https://doc.owncloud.org/server/latest/admin_manual/issues/general_troubleshooting.html?highlight=expected%20filesize#common-problems-error-messages


#7

Hi Tom,
actually I've already come across this page when searching for an answer in the web, but discarded it quickly because I thought it's related to webdav access. Now I checked the logs and it says "webdav" also. So I'll check it out again.
Thanks,
Markus