Upload works fine - "processing files" hangs if file >5MB


i have installed owncloud on https://docs.dezos.io and it worked fine. Upload is possible, but only if smaller than 5MB. If i try to upload a file with 10MB, the upload works, but the "processing files" hangs. Every limit is set high enough.
The logfile says:
2018/05/08 14:26:12 [error] 7346#0: *2848 access forbidden by rule, client:, server: docs.dezos.io, request: "MOVE /remote.php/dav/uploads/Brian/web-file-upload-188c3ad3502382c08f2ba13a341eac33-1525782278578/.file HTTP/1.1", host: "docs.dezos.io"

Are you uploading with the Web UI or sync client?

Use the template. What ownCloud version? What apps do you have installed? Logs?

It seems a problem with the apache configuration, so please also check if apache is somehow blocking the operation.

Web UI direct in Browser

I have the same problem. I have a new installation in 1blu.
The Limit on the Server is 513MB. This settings are in the .user.ini which is in the owncloudfolder in the webspace.
I have look to this settings with phpinfo.
The Upload with webclient work fine but not with the windowsclient.
First I saw that some pictures will not be copy to the server and they get no green sign. In this case the file was greater the 5MB. Then I don't understand that the folder gets the green sign although the sync not work correct. I will use the opencloud because the data are on my own server but in this moment I am not happy with this.
Please give us information what we have to thange.

Can you both provide information about your setup as much as possible?

That would help finding the problem.

Steps to reproduce


Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:

Web server:


PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/...

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/...

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration


Operating system:


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

Version 10.0.7 No apps installed. Just the OwnCloud on my server. I also contacted my hoster, but they have no solution.

I also write here that I have the Problem but now it works and I don't know why.
I have tested it 2 days and get the same problem that at 5MB ist the Limit.
Then I have load files in the Webinterface to test this and this works. After this I wrote the message.
Yesterday after the quick responce from dmitry I tryed again but the system work. At that point on my server were PHP7.0. I have changed this to 7.2.
Now It works fine. I test something with 2 PC. Change text in files and so. After 1 min all is updated.
Very good ,Thank you

I’d try to set it up in a different environment and try to reproduce the error. I still think it’s an environment problem.

You can also try to increase the chunk size for the desktop client: https://doc.owncloud.org/desktop/latest/advancedusage.html . Basically, try to use a size big enough to use only one chunk. It should upload the whole file in one go.

I have the same problem, after upload a big file (204GB) via web browser, it hangs processing files.
I am also facing problem with timeout. I lot of headache.

My setup

ownCloud 10.0.2 (stable)
Php 7.2.17
Centos 7.5.1804
Kernel 3.10.0-862.el7.x86_64
Server version: Apache/2.4.6

I did all that is telling to do here: https://doc.owncloud.org/server/9.0/admin_manual/configuration_files/big_file_upload_configuration.html

Any help?


please update to the latest version, 10.0.2 is not recent.

What apps do you have enabled?

Hi Dmitry,

Those are my apps enabled

Admin Config Report
Deleted files
Provisioning API
Share Files
Update notification
Collaborative tags
First run wizard
Video player

I going to update it, cause I am struggling to do owncloud useful for us. We have big files to upload and until now no success, the last error now is error while assembling parts at all status code 404


i am Also same Problem with the big file 300GB.

Yes, I upgraded my onwcloud to the latest version 10.1.1
and the problem keeps the same, it hangs processing files.

any help?


Steps to reproduce

  1. I am trying to upload a big file (205GB) through web browser(google chrome,mozila firefox )

  2. Then after some hours, it hangs processing files

Expected behaviour

Tell us what should happen

It should upload my file.

Actual behaviour

After hours, it hangs processing files

Server configuration

Operating system: CentOS Linux release 7.5.1804 (Core)

Disk: NLSAS 7.2k

Web server: Server version: Apache/2.4.6 (CentOS)

Database: 5.5.60-MariaDB

PHP version: PHP 7.2.17

ownCloud version: 10.1.1 (stable)

Updated from an older ownCloud or fresh install: Upgraded install

Where did you install ownCloud from:

Repo Centos

Signing status (ownCloud 10.1.1 and above):

No errors have been found.

The content of config/config.php:

"system": {
"updatechecker": false,
"instanceid": "oc8wvr7vhndq",
"passwordsalt": "REMOVED SENSITIVE VALUE",
"trusted_domains": [
"datadirectory": "/owncloud/data",
"overwrite.cli.url": "http://xx.xx.xx.xx/owncloud",
"dbtype": "mysql",
"version": "",
"dbname": "owncloud",
"dbhost": "localhost",
"dbtableprefix": "oc_",
"logtimezone": "UTC",
"installed": true,
"loglevel": 2,
"maintenance": false
"apps": {
"backgroundjob": {
"lastjob": "5"
"comments": {
"enabled": "yes",
"installed_version": "0.3.0",
"types": "logging,dav"
"configreport": {
"enabled": "yes",
"installed_version": "0.1.2",
"types": "filesystem"
"core": {
"enable_external_storage": "yes",
"first_install_version": "",
"installedat": "1547730147.3812",
"lastcron": "1556641591",
"lastupdateResult": "[]",
"lastupdatedat": "1556624868",
"oc.integritycheck.checker": "[]",
"public_files": "files_sharing/public.php",
"public_webdav": "dav/appinfo/v1/publicwebdav.php",
"vendor": "owncloud"
"dav": {
"enabled": "yes",
"installed_version": "0.4.0",
"types": "filesystem"
"federatedfilesharing": {
"enabled": "yes",
"installed_version": "0.3.1",
"types": "filesystem"
"federation": {
"enabled": "yes",
"installed_version": "0.1.0",
"types": "authentication"
"files": {
"cronjob_scan_files": "500",
"enabled": "yes",
"installed_version": "1.5.2",
"types": "filesystem"
"files_external": {
"enabled": "yes",
"installed_version": "0.7.1",
"ocsid": "166048",
"types": "filesystem"
"files_sharing": {
"enabled": "yes",
"installed_version": "0.11.0",
"types": "filesystem"
"files_trashbin": {
"enabled": "yes",
"installed_version": "0.9.1",
"types": "filesystem"
"files_versions": {
"enabled": "yes",
"installed_version": "1.3.0",
"types": "filesystem"
"files_videoplayer": {
"enabled": "yes",
"installed_version": "0.9.9",
"types": ""
"firstrunwizard": {
"enabled": "yes",
"installed_version": "1.1.1",
"ocsid": "166055",
"types": ""
"market": {
"enabled": "yes",
"installed_version": "0.4.0",
"market": "0.3.0",
"signed": "true",
"types": ""
"notifications": {
"enabled": "yes",
"installed_version": "0.4.1",
"types": "logging"
"provisioning_api": {
"enabled": "yes",
"installed_version": "0.5.0",
"types": "prevent_group_restriction"
"systemtags": {
"enabled": "yes",
"installed_version": "0.3.0",
"types": "logging"
"updatenotification": {
"enabled": "yes",
"installed_version": "0.2.1",
"types": ""

List of activated apps:


- comments: 0.3.0

- configreport: 0.1.2

- dav: 0.4.0

- federatedfilesharing: 0.3.1

- federation: 0.1.0

- files: 1.5.2

- files_external: 0.7.1

- files_sharing: 0.11.0

- files_trashbin: 0.9.1

- files_versions: 1.3.0

- files_videoplayer: 0.9.9

- firstrunwizard: 1.1.1

- market: 0.4.0

- notifications: 0.4.1

- provisioning_api: 0.5.0

- systemtags: 0.3.0

- updatenotification: 0.2.1


- encryption

- external

- user_external

Are you using external storage, if yes which one: no

Are you using encryption: no

Are you using an external user-backend, if yes which one: no

Client configuration

Browser: Google Chrome

Operating system: Windows 8.1

I am looking for a solution ! thanks

After about 1 hours of processing files, then finally it uploaded the file.
But now I got another error. Upload timeout
It has happened when I send a public link to someone upload files.



maybe your file storage isn’t fast enough to handle such huge files in a reasonable amount of time? I had some similar experiences where moving to a SSD-based RAID drastically improved my upload experiences with ownCloud.