Upload works fine - "processing files" hangs if file >5MB

hosting

#1

Hi,

i have installed owncloud on https://docs.dezos.io and it worked fine. Upload is possible, but only if smaller than 5MB. If i try to upload a file with 10MB, the upload works, but the "processing files" hangs. Every limit is set high enough.
The logfile says:
2018/05/08 14:26:12 [error] 7346#0: *2848 access forbidden by rule, client: 46.237.218.184, server: docs.dezos.io, request: "MOVE /remote.php/dav/uploads/Brian/web-file-upload-188c3ad3502382c08f2ba13a341eac33-1525782278578/.file HTTP/1.1", host: "docs.dezos.io"


#2

Are you uploading with the Web UI or sync client?


#3

Use the template. What ownCloud version? What apps do you have installed? Logs?

It seems a problem with the apache configuration, so please also check if apache is somehow blocking the operation.


#4

Web UI direct in Browser


#5

Hello
I have the same problem. I have a new installation in 1blu.
The Limit on the Server is 513MB. This settings are in the .user.ini which is in the owncloudfolder in the webspace.
I have look to this settings with phpinfo.
The Upload with webclient work fine but not with the windowsclient.
First I saw that some pictures will not be copy to the server and they get no green sign. In this case the file was greater the 5MB. Then I don't understand that the folder gets the green sign although the sync not work correct. I will use the opencloud because the data are on my own server but in this moment I am not happy with this.
Please give us information what we have to thange.


#6

Can you both provide information about your setup as much as possible?

That would help finding the problem.

Steps to reproduce

1.
2.
3.

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:

Web server:

Database:

PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/...

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/...

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#7

Version 10.0.7 No apps installed. Just the OwnCloud on my server. I also contacted my hoster, but they have no solution.


#8

I also write here that I have the Problem but now it works and I don't know why.
I have tested it 2 days and get the same problem that at 5MB ist the Limit.
Then I have load files in the Webinterface to test this and this works. After this I wrote the message.
Yesterday after the quick responce from dmitry I tryed again but the system work. At that point on my server were PHP7.0. I have changed this to 7.2.
Now It works fine. I test something with 2 PC. Change text in files and so. After 1 min all is updated.
Very good ,Thank you


#9

I’d try to set it up in a different environment and try to reproduce the error. I still think it’s an environment problem.

You can also try to increase the chunk size for the desktop client: https://doc.owncloud.org/desktop/latest/advancedusage.html . Basically, try to use a size big enough to use only one chunk. It should upload the whole file in one go.