User_ldap no users


#1

Ubuntu 16.04 owncloud version: 10.0.2.1

When I add ldap users they don't show up until I manually sync

The issue now is that the users don't show up in their individual groups only everyone and admin (which contains one user)

I am still having this issue that no one is able to help with
{"reqId":"dO9T9qJIxeavmduoJ5dl","level":3,"time":"2017-07-13T12:30:23+10:00","remoteAddr":"192.168.158.24","user":"admin","app":"PHP","method":"POST","url":"\/index.php\/apps\/user_ldap\/ajax\/wizard.php","message":"ldap_search(): Partial search results returned: Sizelimit exceeded at \/var\/www\/html\/owncloud\/apps\/user_ldap\/lib\/LDAP.php#255"}

I've tried changing the user_ldap/lib/Access.php from 500
$maxResults = $pagingSize > 20 ? $pagingSize : 1500;
but hasn't made a difference


#2

The users only start to show up, when they have logged in!


#3

Hi there thanks for your reply
So that's a new feature now and is working as intended?
I was thinking that might be the case


#4

Personally i'm always checking the release notes of a new major release:

https://doc.owncloud.org/server/latest/admin_manual/release_notes.html

which explains the following:

5. Existing LDAP users will only show up in the user management page and in the share dialog after they have been synced. The account table introduced in ownCloud 10.0.0 significantly reduces LDAP communication overhead. Password checks are yet to be accounted for. LDAP user metadata in the account table will be updated when users log in or when the administrator runs occ user:sync "OCA\User_LDAP\User_Proxy". We recommend setting up a nightly Cron job to keep metadata of users not actively logging in up to date.


#5

Thanks for the confirmation, I will check the release notes in the future