User List Suddenly Shows Long String Of Alphanumeric Instead Of Username

10

#1

Greetings,

I hope you are well. I’m playing around the ownCloud 10.0.8 appliance and suddenly some of the users’s in our user list has had their username replaced with a long string of alphanumeric characters. Excuse the ignorance, I’m still new to ownCloud. Any assistance will be greatly appreciated.

Steps to reproduce

  1. Open Users pane in the top right under user’s pull down.

Expected behaviour

Usernames should be shown.

Actual behaviour

Usernames are shown as a long string of alphanumeric characters.

Server configuration

Operating system:
ownCloud Appliance 10.0.8 - Output of uname -a = Linux acc-cloud 4.9.0-6-amd64 #1 SMP Debian 4.9.88-1+deb9u1 (2018-05-07) x86_64 GNU/Linux

Web server:
Output of apachectl -v = Server version: Apache/2.4.25 (Univention)

Database:
MySQL

PHP version:
Output of php -v = php: command not found

ownCloud version:
10.0.8

Updated from an older ownCloud or fresh install:
Fresh Install From Appliance

Where did you install ownCloud from:

List of activated apps:
Output of “sudo -u www-data php occ app:list” = php: command not found

Are you using external storage, if yes which one:
No.

Are you using encryption: yes/no
No.

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…
LDAP - Univention Corporate Server

LDAP configuration (delete this part if not used)

Output of “sudo -u www-data php occ ldap:show-config” = php: command not found

Client configuration

Browser: Chrome

Operating system: MacOS 10.13.5


#2

Hi,

could you explain what do you mean by “suddenly”?

what did you do before this occured?

This should be in the steps to reproduce.


#3

Hi,

Thanks for your reply and it happened suddenly. Before the weekend when I was using it the user list was fine. After the weekend I logged in, the long string of alphanumeric characters appeared in place of SOME usernames. I did not use the ownCloud or touched the server over the weekend. The only thing I noticed is that there was a power failure to the server over the weekend.

Regards,
David,


#4

Okay.

First it would be nice to know how long did you have the appliance.
Did you setup the Appliance on Friday, and then came to see the problem on Monday?

Second - LDAP.
LDAP is a user management system. The Appliance has it’s own LDAP that comes because of univention, the partner company with whom we are developing the appliance.

For ownCloud to know what user is who, it needs an identifier, something no recognize the LDAP users and to address them files and shares. This has to be unique, it can’t be the givenname, since they can repeat in a large company. So ownCloud, if it is not given any other configuration, will create an alphanumeric unique identifier for each user that comes from LDAP. That is what you are seeing right now, right?

This is not an error, but just an un-configured state of the ownCloud LDAP app.

If you would rather have the samaccountname of the users instead of this numbers, just enter this attribute in the expert tab in the first field, Internal User Name and perform an user:sync, or wait 10 minutes for the user sync to be triggered automatically.


#5

Hi dmitry,

Thanks again for your reply. I’ve had the appliance running for a few weeks, just weird that this occurred now.

Yes it sounds like I am seeing this unique ID. Just confirming the attribute is “samaccountname”? Also how do I perform a “user:sync”? Is that with the OCC command? If that is the case, I cannot run OCC command, as it cannot find php, even if I navigate to the /var/lib/univention-appcenter/apps/owncloud.

Regards,
David.


#6

Hi David,

You were correct to try the occ command in the ownCloud directory, this is where you usually execute it.

But, the Appliance is an Univention Server + ownCloud Docker Container. That means - ownCloud is running is a separate environment from the host system, where you are now.

To access the Docker container execute

univention-app shell owncloud

Then you will be inside the docker container in the ownCloud directory.

Here you need to execute the following ( Without sudo -u www:data php . That is taken care of already)

occ user:sync "OCA\User_LDAP\User_Proxy" -m remove

With this - you sync the LDAP users with your current ownCloud LDAP settings.

-m remove : removes the stale not current users from ownCloud