Users in group not displayed

upgrade
10

#1

Hello together,

we upgrade to owncloud 10.0.8.5 and since this upgrade, the users in Groups not displayed anymore.
The users are in the group, but not displayed in the group view on the left menu of “users”.
We run owncloud on Ubuntu 16.04. and we use the LDAP plugin.

Dou you have any hint, about this problem ?

Thanks in advance.

Patrick


#2

Did you run user:sync?

sudo -u www-data php occ user:sync "OCA\User_LDAP\User_Proxy" -m remove

this has to be run in your owncloud directory


#3

thanks for your reply. Yes I did it after the upgrade to add the LDAP users. I ran it again, but the problem ist still there…


#4

Do you have an Active Directory Domain Controller as your LDAP?

If so, please check in the advanced settings if the groups association is on Member(AD)

also every time you change something you need to run the user:sync command


#5

thanks. But our groups not from the LDAP, the groups were created manually in Owncloud and we added the LDAP users. We are using LDAP group only to control who can access the Owncloud.


#6

Okay, do you have special characters in group names?

Like space or something else?

“First Group” or are the names in another language than english?


Issue with user groups (8.1.1 > update > 8.2.latest)
#7

oh, you are right. The problem occures only with groups, which have spaces or an “&,ä,ü,ö” etc. in the name. The most names are in german. Is there a solution to fix this, without to change the names of the group ?


#8

In the upcoming 10.0.9 there is a fix.

It should be released very soon.

If you don’t want to wait or are hesitant to upgrade, here is the patch:

basically you need to edit this file

lib/private/AppFramework/Routing/RouteConfig.php

its in your ownCloud directory.

You don’t need to bother with the second edited file in the Pull Request, this is just for tests.


#9

thanks, i will wait for the next release.
many thanks again.

kind regards
Patrick


#10

today I installed 10.0.9 from testing repo. The problem with groups names still exists. I dont find the fix in the release notes. Do you have news to this problem ?

thanks.


#11

You are correct. We are investigating this atm and will report back to you.

The Fix was to late made and did not make it in the release. Next release, 10.0.10, should include the fix.


#12

Hi, I’ve a similar problem, and I’ve an Active Directory Domain Controller as LDAP.
I’ve checked and the members are on the security groups on AD in advenced settings.
The groups are imported to owncloud, but users are not assigned to groups.
The only group marked on owncloud is domain users and “Tots”, a group where nearly everyone is.

Can you help me?


#13

Check the group member association in advanced settings


#14

In AD? The members are in the group I’ve a 2012 windows and there’s no advanced options…
I’ve made more tests…
If I quit one member in a group (in AD) and use (in owncloud) ‘sudo -u www-data php occ ldap:update-group group-name’, it says removed users: username
If I add again, and use ‘sudo -u www-data php occ ldap:update-group group-name’, it says new user: username
Then the user is added… but when checking with “sudo -u www-data /var/www/owncloud/occ user:list-groups username”
It only shows two groups, “domain users” and “Tots”, there’s no sign of the usergroup used in the test


#15

After some more tests, it seems that users can only be on 2 owncloud usersgroups…
If I add a third one, or dind’t shown, or dissapears a previous one…


#16

Just solved finding and old question made by myself and finded the correct solution on other thread.
previous question
solution