Virtual files won't open on Ubuntu 20.04.2 LTS

I installed the owncloud client on Ubuntu 20.04.2 LTS, version 2.5.1 sync client. I selected virtual file system at install. It synced and created folders with meta data .owncloud files.

They are not linked to ownCloud. Double click opens the file in TextEditor.

Also, there is no context menu option to make available locally like with windows or mac.

How can I link the .owncloud files to ownCloud?

Any suggestions would be great.

Expected behaviour

.owncloud files should open with ownCloud. ownCloud should download file and open with associated program .

Actual behaviour

double clicking file open text edit.

Steps to reproduce

  1. install owncloud on ubuntu linux
  2. sync file
  3. double click .owncloud file

Client configuration

Client version: 2.5.1

Operating system: Unbuntu 20.04.2

OS language: english

Sounds very old, current is 2.7.6
https://download.owncloud.com/desktop/ownCloud/stable/latest/linux/download/

Perhaps you are just missing the file explorer integration?

Hello,
Oh, okay. I installed from Ubuntu software installer. Maybe that option should be updated too.

I’ll try your link.

Thanks.

Any non rolling release distribution will freeze software version at a certain state and not upgrade further until you do a release upgrade.

These packages are maintained by Ubuntu, while under the link I posted you’ll find the packages maintained by ownCloud.

Hello,

I followed the instructions. I’m now running a current version that looks associated with owncloud now.

It says it is syncing. However, I still do not get a context menu option to share files or do other things that Mac or windows context menu offers. Is this just how the Ubuntu Linux version works?

Thanks for clarifying why the old version was offered. It is easy for a 3rd party to loose track of what they offer if there is no automated method to update.

I’ll wait for sync to complete and try opening a file.

Thanks again.

Hello,

Strange that the sync was trying to download all files when virtual files were enabled. I stopped the sync and was able to find the ‘free up disk space’ on the sync tool that cleared up the download issue.

However, I still do not see a context menu to selectively make available locally or free up disk space. It is all or nothing.

Thanks again for the help.

I just had a look in my Kubuntu installation, and it doesn’t seem to have the context menu available in Dolphin either. However I also have an OpenSuse KDE installation and there it just worked out of the box.

The difference would be that OpenSuse is a rolling release distribution where the packages are maintained by Suse and not installed through ownCloud.

So there very well could be a bug in the official ownCloud packages.

What OS/DE are you using?

EDIT: I noticed I had syncing paused for that particular sync connection. I re-enabled it and now I can also see the ownCloud context menu.

EDIT II: I can confirm, if sync connection is paused, ownCloud context menu won’t be shown.

eneubauer@localhost :~$ dpkg -l | grep owncloud
ii  owncloud-client:amd64                         2.7.6+oc-3261                               amd64        The ownCloud sync client - github.com/owncloud/client
ii  owncloud-client-dolphin                       2.7.6+oc-3261                               all          Dolphin plugin for owncloud
ii  owncloud-client-l10n                          2.7.6+oc-3261                               all          Internationalization files for ownCloud
ii  owncloud-client-overlays-icons                2.7.6+oc-3261                               all          overlay icons for owncloud client plugins
1 Like

Client configuration

Client version: 2.5.1

Operating system: Unbuntu 20.04.2

OS language: English

Sync not paused. Only menu item on context menu is “open with owncloud desktop sync client”

Thanks,
Mike

I meant desktop environment with DE, sorry about that. I’m using KDE, which is using Dolphin as file explorer.
Which ownCloud packages do you have installed? Output of `dpkg -l | grep owncloud``

1 Like

~$ dpkg -l | grep owncloud
ii owncloud-client:amd64 2.7.6+oc-3261 amd64 The ownCloud sync client - github.com/owncloud/client
ii owncloud-client-doc 2.5.1.10973+dfsg-1ubuntu4 all ownCloudSync folder synchronization - documentation
ii owncloud-client-l10n 2.5.1.10973+dfsg-1ubuntu4 all ownCloudSync folder synchronization - localization

EDIT: maybe I should remove and reinstall. I see some 2.5.1 items still installed above.

EDIT: I tried to remove owncloud via the Ubuntu software installer. It won’t remove owncloud due to unmet dependencies.

apt-get -f install?

Perhaps remove the repo again, remove the packages, and then re-add the repo and reinstall new version of ownCloud?

EDIT: Also, you don’t seem to have an ownCloud file explorer package installed on your system.

1 Like

~$ sudo apt-get -f install
[sudo] password for mbrando:
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

With Linux it is more complicated to get the right click menu. We have client extension packages for many different Linux File Browsers, but unfortunately we don’t install them by default (this would currently install way too many dependencies).

We have owncloud-client-nautilus, owncloud-client-nemo, owncloud-client-caja, and owncloud-client-dolphin. Please check which File browser you have, and install the respective package. Sometimes a logout/login is also needed to make the right click menu work.

2 Likes

Thanks, I’ll try this later today.

Hello, My Linux file browser is called Files.

Hello,

I installed owncloud-client-nautilus. Now I have the context menu!! :slight_smile:

Thank you.

3 Likes

“Files” is really an unfair name :wink:
Glad you made it!

I really lack a good idea, how to better automate the installation of file browser integration packages. Bundling them all with the client cannot be done. It would cause dependency bloat (A gnomish desktop receives half of KDE and vice versa…).

the best idea, we know so far is to let the client check the environment at runtime and make some kind of suggestion to the user which file browser(s) seems to installed and/or in use…
But that sounds like relying on horrible heuristis…

1 Like