Web interface --no option to add a file, when downloading a file i get a 403 forbidden error


#1

Steps to reproduce

Expected behaviour

Tell us what should happen
download the file from web interface to the local machine

Actual behaviour

Tell us what happens instead
using the web interface, when downloading a file I get a 403 forbidden error.

Server configuration

Operating system:
CentOS 7

Web server:
Apache

Database:
MariaDB

PHP version:
7.2.9

ownCloud version: (see ownCloud admin page)
10

Updated from an older ownCloud or fresh install:
fresh
Where did you install ownCloud from:
https://download.owncloud.org/download/repositories/10.0/CentOS_7/ce:10.0.repo
Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no
no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

Can you look in to the server log file to find the exact error message?


#3

I fix it. It was a SELinux issue. Now I can download my files.
However the other issue… I have no clue how to fix it. In my web interface, I don’t have an option to add a file, I can only add a folder. Any idea?

thank you !


#4

How about another SELinux issue?


#5

nope, i’m cutting off SELinux but the issue is still there. I do have the option to create a folder only.


#6

Hey,

maybe you can explain this in some more details / with a screenshot?


#7

@dmitry told you to check the logs. Anything new you can tell us?


#8

owncloud

there is a screenshot, I’m supposed to have an option to add a file, right?


#9

{“reqId”:“W4glcNxBYTAzEZuqfPI0gQAAAAc”,“level”:3,“time”:“2018-08-30T17:12:17+00:00”,“remoteAddr”:“68.67.54.138”,“user”:"–",“app”:“PHP”,“method”:“GET”,“url”:"/owncloud/index.php",“message”:“You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/owncloud/lib/composer/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18”}
{“reqId”:“W4gllnEvCxDYYj@H2D9YzwAAAAA”,“level”:3,“time”:“2018-08-30T17:12:54+00:00”,“remoteAddr”:“68.67.54.138”,“user”:"–",“app”:“PHP”,“method”:“GET”,“url”:"/owncloud/index.php",“message”:“You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/owncloud/lib/composer/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18”}
{“reqId”:“W4gmglk0J9lccALnNWFBTgAAAAQ”,“level”:3,“time”:“2018-08-30T17:16:50+00:00”,“remoteAddr”:“68.67.54.138”,“user”:"–",“app”:“PHP”,“method”:“GET”,“url”:"/owncloud/index.php",“message”:“You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/owncloud/lib/composer/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18”}
{“reqId”:“W4gpHAHuxTVXpvmfUYs0pQAAAAA”,“level”:3,“time”:“2018-08-30T17:27:56+00:00”,“remoteAddr”:“68.67.54.138”,“user”:"–",“app”:“PHP”,“method”:“POST”,“url”:"/owncloud/index.php/heartbeat",“message”:“You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/owncloud/lib/composer/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18”}
{“reqId”:“W4gpaQMjHW@XjzCaa@6OuAAAAAE”,“level”:3,“time”:“2018-08-30T17:29:13+00:00”,“remoteAddr”:“68.67.54.138”,“user”:"–",“app”:“PHP”,“method”:“GET”,“url”:"/owncloud/index.php",“message”:“You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/owncloud/lib/composer/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18”}
{“reqId”:“W4gqErJQJkiRkxmmlqIRBQAAAAA”,“level”:3,“time”:“2018-08-30T17:32:03+00:00”,“remoteAddr”:“68.67.54.138”,“user”:"–",“app”:“PHP”,“method”:“GET”,“url”:"/owncloud/index.php",“message”:“You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/owncloud/lib/composer/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18”}
{“reqId”:“W4gqHCda66hRMIT02pqU4AAAAAg”,“level”:3,“time”:“2018-08-30T17:32:12+00:00”,“remoteAddr”:“68.67.54.138”,“user”:"–",“app”:“PHP”,“method”:“POST”,“url”:"/owncloud/index.php/heartbeat",“message”:“You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/owncloud/lib/composer/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18”}
{“reqId”:“W4gsvOQQmsy7iAsSG@H@OgAAAAg”,“level”:3,“time”:“2018-08-30T17:43:24+00:00”,“remoteAddr”:“68.67.54.138”,“user”:"–",“app”:“mysql.setup”,“method”:“POST”,“url”:"/owncloud/index.php",“message”:“Specific user creation failed: An exception occurred while executing ‘SELECT user FROM mysql.user WHERE user=?’ with params [“oc_OwnCloud_USER”]:\n\nSQLSTATE[42000]: Syntax error or access violation: 1142 SELECT command denied to user ‘OwnCloud_USER’@‘localhost’ for table ‘user’”}
{“reqId”:“W4gsvOQQmsy7iAsSG@H@OgAAAAg”,“level”:3,“time”:“2018-08-30T17:43:25+00:00”,“remoteAddr”:“68.67.54.138”,“user”:"–",“app”:“no app in context”,“method”:“POST”,“url”:"/owncloud/index.php",“message”:"User backend OC\User\Database is returning home: /storage/OwnCloud_USER for user: OwnCloud_USER which differs from existing value: "}


#10

Yes, you can. With “Upload” if you want to create a new text file you need the text editor app from market.


#11

thank you so much !! All good now :slight_smile:


#12

Glad to hear that. So what was missing in your instance was the text editor app?


#13

Hey,

even if this is working now as expected i would suggest to at least fix this issue as advised in the logs:


#14

Here I have missed something. What about all the ugly errors in the log? They all are solved?


#15

yes, i thought it comes with the installation itself and not as an app.


#16

I’m using CentOS 7, I tried running:
yum --enablerepo=remi install php-intl
but i get:
“Package php-intl-7.2.9-1.el7.remi.x86_64 already installed and latest version
Nothing to do”
…not sure what else I could try.


#17

I don’t know if this is a real problem, but AFAIK oC officially supports up to php 7.1.


#18

Could you open a separate issue for that?

The issue of the title is resolved as far as I understand.


#19

I assume you wanted to reply to the OP. :wink:


#20

sure, but since you brought up the question :slight_smile: