Web login ok desktop 403 forbidden

Steps to reproduce

  1. Install owncloud server on unraid
  2. Install OAuth2 app
  3. Install 2FA and activate
  4. Try to login on web = ok
  5. Try to login on desktop client - 403 forbidden

Expected behaviour

It should prompt me to grant access from desktop client request on browser and do 2FA then automatically go back to desktop client

Actual behaviour

403 forbidden error

Server configuration

Operating system:

Web server:
I don’t know. sorry I’m noob. Is it nginx?


PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:
fresh install

Where did you install ownCloud from:
unraid community apps (dlandon’s Repository)

Signing status (ownCloud 9.0 and above):
I don’t know what’s this?

Login as admin user into your ownCloud and access 
paste the results into https://gist.github.com/ and puth the link here.

It says “No errors have been found.”

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:
2FA, OAuth2

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

Client configuration


Operating system:
Win 11


Web server error log

owncloud.log (502.6 KB)

ownCloud log (data/owncloud.log)

owncloud.log (502.6 KB)


I tried to research and edit .htaccess on owncloud and set

`SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1`

Restarted owncloud docker but no avail. Still 403 forbidden error.

I think the problem is with the nginx. If I disable OAuth2 app and have only 2FA activated it works using app password. If I put the local address in the desktop client, OAuth2 works. But I don’t know how to fix this 'coz I don’t have enough knowledge on this. I just rely on guides, videos etc.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.