Webdav and windows 10

9.1.x

#1

Hi, I try to connect to my owncloud 9.1 from the webdav client that comes with my Windows 10 (64-bit). In the brower I can connect to owncloud with
https://owncloud.site01.com
(it takes me to the login page)
Also the desktoop sync-client works fine.

But I need to run owncloud over WebDAV. I run from cmd commands like

net use Z: https://owncloud.site01.com/remote.php/dav/files/USERNAME/ /user:myuser mypass
System error 1244 has occurred.
The operation being requested was not performed because the user has not been authenticated.

But as is evident - it does not work. I get the 1244 error.
In the registry I have UseBasicAuth=2
I run Debian with apache 2.4. In my apache ssl config-file I have
SSLProtocol all

My owncloud VirtualHost in apache is configured to only run over SSL.
I have read the forum post 11246
and done what is being suggested.
Sorry for not linking to it but this forum software says new members can only put two links in a post... really??

Any thoughts?


#2

The Windows implementatio of WebDAV has always its own fun. If possible I recommend a WebDAV Client like Cyberduck. Othewise, maybe you can try it against our demo system at demo.owncloud.com (admin/admin) and see if it works there.


#3

Hello , in 10.0.3 , this bug is fixed.


#4

Hi,
in the first post I wrote that I had owncloud 9.1. That is wrong - it is 10.0.1. I am still not able to connect my owncloud installation.

I was easily able to connect to the demo system. From the command line I ran:
net use Z: https://demo.owncloud.com/remote.php/webdav /user:admin admin
and it went right in. I can not modify documents on the server or add documents - but I guess that is a matter of user configuration for the demo system.

What version is the demo system? Is it 10.0.3?

My 10.0.1 is a test system for me - a newbie. I run VirtualBox on my Win10 machine. And Debian 9.1 (thats where the 9.1 came from I guess) as a virtual machine. owncloud is installed on the Debian. Next week I will set up more of a production owncloud. So if the latest release, 10.0.3, has fixed this error, everything is good.


#5

Hi again. I think I actually do have owncloud 10.0.3. Under the link in the top right corner - Settings - General. At the bottom of the page it says

Version
ownCloud 10.0.3 (stable)
Developed by the ownCloud community, the source code is licensed under the AGPL.

(if you go under -help the help page says "What is new in 10.0.1". So that is why I thought I had 10.0.1)

Cyberduck: webdav to my owncloud server works. I can also connect to demo.owncloud.com.
I have a self-signed certificate on the server - and get warnings. Both connection and download works.
However, I would be interested in why the native Win10 webdav client works against demo.owncloud.com but not against my server. I have Apache2.4. I am fairly new to apache but have tried to make the configuration as basic as possible.The domain owncloud.site01.com is a VirtualHost and set up so that http requests are redirected to https. The defaultssl.conf file is:

ServerName owncloud.site01.com
DocumentRoot /var/www/owncloud
SSLEngine On
SSLProtocol all
SSLCertificateFile /etc/ssl/localcerts/owncloudcert.pem
SSLCertificateKeyFile /etc/ssl/localcerts/owncloudcert.key

I installed owcloud according to
http://download.owncloud.org/download/repositories/10.0/owncloud/

Any thoughts about what could be wrong on my system?