Webdav can't get on folder level

webdav_issue

#1

Steps to reproduce

  1. Try to get command with webdav on folder level
  2. you get 200 response which means OK
  3. Indeed no folder has been synced

Expected behaviour

I should get the folder synced if have got perms to that

Actual behaviour

Get 200 response and nothing happened

Server configuration

Operating system: Ubuntu 16.04.4 LTS

Web server: Apache/2.4.18 (Ubuntu

Database: mysql Ver 14.14 Distrib 5.7.24

PHP version: PHP 7.0.32-0ubuntu0.16.04.1

ownCloud version: (see ownCloud admin page) 10.0.10.4

Updated from an older ownCloud or fresh install: previous

Where did you install ownCloud from: repo

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

No errors have been found.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Enabled:

  • activity: 2.4.1
  • comments: 0.3.0
  • configreport: 0.1.1
  • customgroups: 0.4.0
  • dav: 0.4.0
  • federatedfilesharing: 0.3.1
  • federation: 0.1.0
  • files: 1.5.1
  • files_external: 0.7.1
  • files_pdfviewer: 0.10.0
  • files_sharing: 0.11.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • firstrunwizard: 1.1
  • gallery: 16.1.1
  • guests: 0.7.0
  • market: 0.3.0
  • notifications: 0.3.5
  • password_policy: 2.0.2
  • provisioning_api: 0.5.0
  • security: 0.0.2
  • systemtags: 0.3.0
  • updatenotification: 0.2.1
  • user_ldap: 0.13.0
    Disabled:
  • encryption
  • external
  • files_videoplayer
  • user_external
  • xmas

Are you using external storage, if yes which one: local/smb/sftp/…
no

Are you using encryption: yes/no
no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…
webdav

LDAP configuration (delete this part if not used)

can’t provide

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

I don’t understand you problem. Could you explain more in detail?


#3

Hi,
Sure! For me it’s also strange behavior I could see.
We have CRM software that uses offline sync with sync based on files. Those files are placed on owncloud folder via owc client. The problem is that CRM client tries to use GET method to get list of files in folder and receives 200 but no list is returned.
Maybe screen below will explain it more:


Any idea how to get it working?


#4

Hi Alfred,
Any comments to my response?
Thanks,


#5

Yes , sorry for the delay.

As you can see at the right side of your pic, the client you are using doesn’t use WebDAV protocol. But this is a must for communicating with ownCloud.