WebDav Error (400 Bad Request) PROPFIND

Expected behaviour

We upgraded owncloud from version 10.0.3 to 10.0.9. After upgrade we are unable to login to owncloud to synchronize files remotely using the owncloud desktop client app. We receive the following error messages when accesing the Web Interface and using the client to sync files see attached screenshots. HOW DO WE GET THE WEBDAV CORRECTLY CONFIGURED ON THE SERVER? IS THERE A LINK REFERENCE TO SHOW HOW TO CORRECTLY SET UP WEBDAV?

Client Login Screen Screenshot:

Web Interface Setting Screenshot:

Actual behavior

When entering username and password into client an error message results saying "Server replied “400 Bad Request” to “PROPFIND https://scloud.shinshuri.com/remote/webdav/

Steps to reproduce

  1. Open Desktop App
  2. Enter Server Address
  3. Enter Username
  4. Enter Password
  5. Click Submit

Server configuration

Operating system: CENTOS 6.10

Web server: Linux

Database: MySQL

PHP version: 5.6

ownCloud version: 10.0.9

Storage backend (external storage):

Client configuration

Client version: 2.4.2

Operating system: Windows 10

OS language:

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client: C:\Program Files (x86)\ownCloud\owncloud.exe


Please use Gist (https://gist.github.com/) or a similar code paster for longer

Template for output < 10 lines

  1. Client logfile: Output of owncloud --logwindow or owncloud --logfile log.txt
    (On Windows using cmd.exe, you might need to first cd into the ownCloud directory)
    (See also http://doc.owncloud.org/desktop/2.2/troubleshooting.html#client-logfile )

  2. Web server error log:

  1. Server logfile: ownCloud log (data/owncloud.log):

I received the following message from IT Support for our webserver.


I have tried everything that is available on the online documents to fix the errors but I am sorry to report that there are still issues that seems to be needing someone from the developer side. For eg the error

The “Strict-Transport-Security” HTTP header is not configured to at least “15552000” seconds. For enhanced security we recommend enabling HSTS as described in our security tips.
This is already set as per the configs, by adding virtual host entry as said on https://doc.owncloud.org/server/9.1/admin_manual/configuration_server/harden_server.html#enable-hsts-label but owncloud is not detecting it.

“Some files have not passed the integrity check”
These relate to the files

  • core/img/favicon.ico
  • core/img/favicon.png
    I am not sure if you have alerted the defaults coming with the installation. Nevertheless it should not cause the issue. If you have not replaced the said files to something from your end, you can fix this by re-downloading the files from owncloud and placing it on the server.

Regarding webdev, I have checked and confirmed there are no server level issues. The error seems to have come after the last update you did to the owncloud, so you need to contact the developers to see if there is a bug or a configuration change that they have added. We have spent hours on this issue and we try our best to resolve third party software related issues but this has reached a point where you need to contact the developers and have them debug this for you. The issue is way beyond the scope of support that we can provide. Once you get the feedback from the developers, please let us know if there is anything that needs to be done from our end on the server, we will be more than happy to check it out for you.

Balakrishnan U
Manager - Technical Support
TotalChoice Hosting, Inc.

See the screenshot of the message as well here:

Can you provide some information and clarity on when this bug issue will be fixed? We are unable to use the desktop app or mobile app and sync to the cloud.

Any help you can provide is greatly appreciated!



from my experience an answer to such a question requires quite a lot additional steps:

  1. Verification if this is really a bug and not an environmental / configuration issue.
  2. A bugreport to a bugtracker.
  3. A developer confirming that it is indeed a bug.
  4. A developer being able to reproduce and fix the bug.
  5. A release date of the new version of the software containing the fix.

While step 1 is something a user of this forums can help you with the other steps are (from what i know) handled in ownCloud at https://github.com/owncloud/core/issues

For step 1. you could help the other users by cleaning your owncloud.log as i don’t think that some one can see any useful information within a 1.6 GB large logfile. :confused:

My guess (w/o further information) is, that the upgrade messed up the config. This is IMHO not a bug, can happen all the time.


You make several suggestions for how to take action on the recommendations. First, where should I begin? Second, How do I clean up the owncloud.org file? Third, how do I determine what is useful or not? I need more specific guidance because I am not a developer.

Fourth, in my initial inquiry, I asked for information or a link on how to configure the webDAV. You have focused your response on my second question about a possible bug. I cannot say it is a bug, but I do know that I upgraded using the Upgrade App using the Web Interface. I have upgraded this way since it was introduced. The last upgrade that I used it was 10.0.3 it worked perfectly. I upgrade to 10.0.9 and the webDAV doesn’t work anymore. That could be perceived as a bug. But, I am not interested in belaboring whether or not it is a bug. I simply want to get the webDAV configured correctly so we can sync files from the Desktop and Mobile apps.



Yes. This issue occurred after the upgrade. I used the Upgrade App button in Owncloud. I don’t know how it got misconfigured if that is the issue. If it is a configuration issue and not a bug (I don’t know, I assumed that it was a bug because of the message from the IT support) then how does the configuration issue get corrected? What are the steps to fix an issue like this one?

Any help is greatly appreciated!



i think most of the users in this forums (including me) don’t have that much knowledge on such topics so i think you may need to work with the information others can provide you :confused:

But i try my best to answer your new questions:


Both questions seems to me related and i think i had provided the information on the “WebDAV interface is broken” issues in another thread: Owncloud Web Interface and Desktop App Not Syncing . That link on the ownCloud documentation seems to be linking back here to the forums: How to fix CalDAV|CardDAV|WebDAV problems which could be a good starting point for you.

From what i know you can delete the owncloud.log and ownCloud will start with a fresh file.

This is where other users in this forums could jump in and support you. But even those can’t help with such a huge owncloud.log so my suggestion was to clean the owncloud.log and then post only the log entries added to the owncloud.log once your issue appears.

I think the main problem is that if it is a bug it requires a developer of ownCloud to have a look at it. And from my experience this will be handled in the github issue tracker like explained earlier. :confused:


Thank you for the additional details! I got your points. When you say

i think you may need to work with the information others can provide you :confused:

Do you mean the GIthub community you referenced earlier? If so, can you provide the link where I can post this issue?



ah no. Sorry, this was not that clearly written by me. :confused:

I just wanted to point out that there can’t be a single solution for a problem (or a solution at all) and users like @alfredb or me are trying to help to the best of their knowledge and provide possible background information.

When you e.g. say “i need more details” or similar people are not always able to provide these details and they already shared everything they know in their previous posts.

Nevertheless to the points above maybe we can already help a little bit better with a stripped down owncloud.log where we could see possible issues.

1 Like


Thanks for the clarification! Per your last comment:

Nevertheless to the points above maybe we can already help a little bit better with a stripped down owncloud.log where we could see possible issues.

I deleted the older owncloud.log file and have attempted to access the service using my desktop app several times. Can you see or detect where the issue might be with this log file.

I am going to look at the other points to see how I might be able to get a resolution to this issue. Let me know.



I read through the link How to fix CalDAV|WebDAV problems per your earlier post cited below:

Both questions seems to me related and i think i had provided the information on the “WebDAV interface is broken” issues in another thread: Owncloud Web Interface and Desktop App Not Syncing. That link on the ownCloud documentation seems to be linking back here to the forums: How to fix CalDAV|CardDAV|WebDAV problems 1 which could be a good starting point for you.

Since, I am no longer getting the same error message as before. Please see my earlier posted image of the desktop app error message. Can the recommended solutions call out in the second link reference help in this situation too?

Please let me know and I’ll have my IT guys check it out.

Hey, i see quite a lot of the “Trusted domain error.” messages in your owncloud.log. Could it be possible that your sync clients are using the wrong domain or that they are getting somehow redirected wrongly?

Hi @tom42

I am using Cloudbric.com an SSL Security Cloud-based Service. Could there be an issue with redirect because there is a redirect of the domain to provide https:// security? We only redirect on the CNAME Record not the nameservers.

But I am also getting the error in the Web Interface about the webDAV and some other things, which suggest there are configuration issues on the server itself as well. See the above screenshot of our owncloud browser screen after login.

Please let me know your perspective.


Hey, maybe this mechanism/service is forwarding all browser related “basic” requests to the correct URL but blocking/wrongly redirecting all WebDAV related requests (used by the Sync Client and this WebGUI test)?


Thank you fro the additional tip. I have temporarily removed the https:// of the subdomain and I am getting the following error now. When the https:// security is enabled I get the previous error (400 Bad Request PROPFIND).

First question, shouldn’t I be able to access remotely regardless of whether or not https is enabled. In other words, I should be able to access remotely if everything is configured properly without https security although it is recommended? Correct?

Second question, is this a server side issue or a bug?

I have received a response back from our IT service provider they have been trying to help me troubleshoot, but they have not found anything on the server side.

Error after https removed on subdomain

Last Response from IT Support

I really need to get this resolved asap. Please let me know.


Does this latest failure produce some content in owncloud.log? Please not the whole file, just the relevant lines, if any. :wink:


i think the old “400 Bad Request” and the new “Access forbidden by server” might still pointing to an issue with the server or the infrastructure running ownCloud rather to ownCloud itself. I’m reposting the information i had posted 10 days ago:

In the second link a tool called “litmus” is mentioned. It seems to me that this could help you to test your server if it fulfills all requirements to run a software like ownCloud requiring a WebDAV to work.

Fully agree with you! The one and only “bug” here is the faulty configuration.

OTOH, still haven’t seen any config part, nor related info from owncloud.log. But:

of course, we are continuing wasting our time. I really like to help, wherever I can. But in the meantime, this issue is beyond my interests.