WebDAV mapping error on Windows 11

Hey on there!

Got trouble with mounting drive through WebDav on Windows 11 desktop clients.
On Windows 10 or 7 was no problems yet for 30+ different users and respectively OS assemblies .

Expected behaviour

Mounting drive using standart command net use or mounting with Windows GUI as Network folder or Mapped Network Drive

Actual behaviour

  1. Tried to map storage with command promt as admin:
    net use X: https://owncloud.mydomain.com/remote.php/webdav /persistent:no /savecred
    net use X: "\\mydomain.com@SSL\remote.php\webdav\" /persistent:no /savecred

Both with error:
System Error 59. Unexpected error (translated as well as i google it)

  1. Tried to use GUI to map network drive. Used address to map like https://owncloud.mydomain.com/remote.php/webdav. After entering credentials just repeately asking for credentials few times:
    and finally got error:
    The mapped network drive could not be created because the following error has occurred A device attached to the system is not functioning (translated as well as i google it)

  2. GUI mapping drive gots error too.

  3. Also tried PowerShell command:
    New-PSDrive -Name R -PSProvider FileSystem -Root "\\owncloud.mydomain.com@SSL\remote.php\webdav" -Credential Get-Credential
    Error occured:
    New-PSDrive : A device attached to the system is not functioning

For sure, next features are set correctly on client Windows 11 to use WebDAV:

  • Network Discovery enabled
  • Webclient service is running
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WebClient\Parameters set:
  • FileSizeLimitInBytes = 0xffffffff
  • FsCtlRequestTimeoutInSec=0xffffffff
  • BasicAuthLevel=2

Server configuration

Operating system: Ubuntu 18.04.4 LTS

ownCloud version: OC 10.8.0 (docker image), SSL secured with Let’s Encrypt using Traefic

Storage backend (external storage): Local storage used

Client configuration

Client version: NO client app used, just windows standard WebDAV features

Operating system: Windows 11

OS language: Russian, Ukrainian


No any events in OC log on server side when mapping commands trying to run! Seems like client even not trying to talk with server.

Thx for any advice. More and more people trying to use new W11 and i bet same troubles will occur more and more in future. Have to be ready for that, dear Community :heart:

So are you saying that Windows 10 and Windows 11 behave differently here? What does MS say about this?

1 Like

I see more or less the same behavior on Windows 10. We have ca. 40 users and get all kinds of errors mapping drives using Webdav. It simply seems that Windows Webdav and ownCloud do not get along very well. Excalating this to the support of our infrastructure provider and ownCloud itself did not yield a stable solution yet.

Seems to be true. According to my experience with Windows (since NT), none of the Windows versions ever could handle WebDAV in a really usable way.

Correct, we and none of our customers was ever happy with the WebDAV experience in Windows 10 … There are some possibilities using Registry changes in both Windows and Office.
Generally we recommend the ownCloud Desktop Client for Windows 10/11 which has full VFS support … can you try that and give feedback …
Alternatively there are WebDAV Clients commercially available which work - like Mountainduck.
But we and our customers are very happy with the ownCloud Desktop Client with the virtual files, would love to learn how it might not fit your use case …

Yes, according to our experience - none of W11 clients able to map OC via native windows WebDAV, but W10 works fine if registry was set correct.

I gonna post some similar topic to MS support in the next few days and will share link here. Maybe, we could define a side of problem - MS or OC.

We just use one cmd to set mapped drive with WebDAV for clients (including windows registry and services settings, mounting drive on startup). User just have to run it once, enter credentials and ready to work.

Our manifests for that (direct mounting network drive via WebDAV satisfying all of them):

  • no VPN
  • one drive name and same path to files (so we coul share links between team and all soft will use same path correctly too)
  • no additional software on client-side have to be installed (including OC client)
  • no files stored on clients side, all files we keep on server

Thanks! If you can, please share the cmds you are using. Any news on your Windows 11 approach?

Hello, fresh installation of w11 here and having the same problem, error 59 on cmd “net use …”

I have switch in the registry editor basicAuthLevel to 2 with no luck

Any hints? Thanks in advance!

1 Like

Hey on there!
Since last replies - updated OC to 10.9.1-rc1 and Ubuntu to 20.04.3 LTS. Got the same stuck.

But I found a duct tape solution and it seems to be a microsoft fault. Posted it on MS QA.

So. Trouble in some dlls, that MS WebDav client uses.
Here they are:

I replaced them from Windows 10 system (but first backuped them, made administrator as owner and granted full permissions to the files. otherway i was not allowed to change them).
WebClient service restart required after manipulations, use in cmd promt as admin for that:
net stop webclient & net start webclient

I dont think its a solution. I hope MS fix this issue and we could close then. Same issue took place past in Windows 10 on 1903 update - found tips in last reply there.

Tested it out on freshly installed W11 from official image in VirtualBox and at one client PC. It works fine now. I hope updates will not rewrite broken files back (


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.