When ownCloud on Nginx, all css is not useful

9.0.x
help

#1

hi:
i am using the naginx.conf on https://doc.owncloud.org/server/9.0/admin_manual/installation/nginx_owncloud_9x.html.
now, i can access the owncloud website, but i can not see styles. it seems like all css can not work.

what should i do now ?

#2

Please post your used nginx config as well as your ownCloud version (At least the oC version is the MINIMUM info you should provide in your thread).


#3

ok.
my ownCloud version is 9.0.2 and my nginx version is 1.10.1

my used nginx config:

events{
    worker_connections 1024;
}

http {
upstream php-handler {
    server 127.0.0.1:9000;
    #server unix:/var/run/php5-fpm.sock;
}

server {
    listen 80;
    server_name cloud.example.com;
    # enforce https
    return 301 https://$server_name$request_uri;
}

server {
    listen 443 ssl;
    server_name cloud.example.com;

    ssl_certificate /etc/ssl/nginx/cloud.example.com.crt;
    ssl_certificate_key /etc/ssl/nginx/cloud.example.com.key;

    # Add headers to serve security related headers
    # Before enabling Strict-Transport-Security headers please read into this topic first.
    #add_header Strict-Transport-Security "max-age=15768000; includeSubDomains";
    add_header X-Content-Type-Options nosniff;
    add_header X-Frame-Options "SAMEORIGIN";
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options noopen;
    add_header X-Permitted-Cross-Domain-Policies none;

    # Path to the root of your installation
    root /var/www/owncloud/;

    location = /robots.txt {
        allow all;
        log_not_found off;
        access_log off;
    }

    # The following 2 rules are only needed for the user_webfinger app.
    # Uncomment it if you're planning to use this app.
    #rewrite ^/.well-known/host-meta /public.php?service=host-meta last;
    #rewrite ^/.well-known/host-meta.json /public.php?service=host-meta-json last;

    location = /.well-known/carddav {
        return 301 $scheme://$host/remote.php/dav;
    }
    location = /.well-known/caldav {
        return 301 $scheme://$host/remote.php/dav;
    }

    location /.well-known/acme-challenge { }

    # set max upload size
    client_max_body_size 512M;
    fastcgi_buffers 64 4K;

    # Disable gzip to avoid the removal of the ETag header
    gzip off;

    # Uncomment if your server is build with the ngx_pagespeed module
    # This module is currently not supported.
    #pagespeed off;

    error_page 403 /core/templates/403.php;
    error_page 404 /core/templates/404.php;

    location / {
        rewrite ^ /index.php$uri;
    }

    location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)/ {
        return 404;
    }
    location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console) {
        return 404;
    }

    location ~ ^/(?:index|remote|public|cron|core/ajax/update|status|ocs/v[12]|updater/.+|ocs-provider/.+|core/templates/40[34])\.php(?:$|/) {
        fastcgi_split_path_info ^(.+\.php)(/.*)$;
        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param PATH_INFO $fastcgi_path_info;
        fastcgi_param HTTPS on;
        fastcgi_param modHeadersAvailable true; #Avoid sending the security headers twice
        fastcgi_param front_controller_active true;
        fastcgi_pass php-handler;
        fastcgi_intercept_errors on;
        fastcgi_request_buffering off;
    }

    location ~ ^/(?:updater|ocs-provider)(?:$|/) {
        try_files $uri/ =404;
        index index.php;
    }

    # Adding the cache control header for js and css files
    # Make sure it is BELOW the PHP block
    location ~* \.(?:css|js)$ {
        try_files $uri /index.php$uri$is_args$args;
        add_header Cache-Control "public, max-age=7200";
        # Add headers to serve security related headers (It is intended to have those duplicated to the ones above)
        # Before enabling Strict-Transport-Security headers please read into this topic first.
        #add_header Strict-Transport-Security "max-age=15768000; includeSubDomains";
        add_header X-Content-Type-Options nosniff;
        add_header X-Frame-Options "SAMEORIGIN";
        add_header X-XSS-Protection "1; mode=block";
        add_header X-Robots-Tag none;
        add_header X-Download-Options noopen;
        add_header X-Permitted-Cross-Domain-Policies none;
        # Optional: Don't log access to assets
        access_log off;
    }


    location ~* \.(?:svg|gif|png|html|ttf|woff|ico|jpg|jpeg)$ {
        try_files $uri /index.php$uri$is_args$args;
        # Optional: Don't log access to other assets
        access_log off;
    }
}
}

#4

Hi,

ok thats the correct official one. This config is known to working on tons of systems out there which don't show this issue. So you need to dig into your environment on your own to see why it is showing such a behavior others won't show.

From the template shown when creating a new thread in the "oC server" category:

Before posting please snip and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

It probably won't solve your issue with the missing .css but before seeking help for possible other issues please first update to at least 9.0.5.


#5

Thanks.I will update 9.0.5 and try again.


#6

As written above it mostly won't solve your issue here. For that own action and research from your side is needed why your environment is showing issues with the same config others won't show.


#7

Do you have the browser errors?
E.g. From "Webinspector" or so?
I guess some references are simply wrong


#8

i hope so.but no.
i have no brower errors and i can use all every thing on ownCloud.


#9

One try: see the source of the OC page and pick one of the css links in the header.
When you copy it into a new window, what happens?


#10

it is not useful.
i add some css links in the header. but it is still missing .css.


#11

I think you need to post more info if you would like to get support.

Copy a link to a css and post here which you copied (the whole link)
Then post what happens if you open this link kn a new window.

Either rhe browser has an issue wirh not processing css or your nginx config is wroch not to serve them