Win build fails


#1

fetched from master

I followed https://doc.owncloud.org/desktop/2.5/building.html instructions
fails with result (pls help):

PS C:\Users\Administrator\client-build> cmake -G “MinGW Makefiles” -DNO_SHIBBOLETH=1 C:\Users\Administrator\client
– Build of crashreporter disabled.
– GIT_SHA1 e87660b
– Could NOT find INOTIFY (missing: INOTIFY_INCLUDE_DIR INOTIFY_LIBRARY_DIR)
– Could NOT find Sphinx (missing: SPHINX_EXECUTABLE)
– Could NOT find PdfLatex (missing: PDFLATEX_EXECUTABLE)
– Using Qt 5.12.0 (C:/Qt/Qt5.12.0/5.12.0/mingw73_64/bin/qmake.exe)
– Using own sqlite3 from C:/Users/Administrator/client/src/3rdparty/sqlite3
– Using own sqlite3 from C:/Users/Administrator/client/src/3rdparty/sqlite3
– Added vfsPlugin without tests: suffix
– Could NOT find Png2Ico (missing: Png2Ico_EXECUTABLE)
– Could NOT find IcoTool (missing: IcoTool_EXECUTABLE)
CMake Warning at cmake/modules/ECMAddAppIcon.cmake:272 (message):
Unable to find the png2ico or icotool utilities or icons in matching sizes

  • application will not have an application icon!
    Call Stack (most recent call first):
    src/gui/CMakeLists.txt:221 (ecm_add_app_icon)

– Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
– Configuring done
CMake Error at src/libsync/CMakeLists.txt:124 (add_library):
Cannot find source file:

…/3rdparty/zsync/c/librcksum/hash.c

Tried extensions .c .C .c++ .cc .cpp .cxx .cu .m .M .mm .h .hh .h++ .hm
.hpp .hxx .in .txx

CMake Error at src/libsync/CMakeLists.txt:124 (add_library):
No SOURCES given to target: owncloudsync


#2

Hey,

maybe the new approach to build the desktop client could help you with the build:


#3

HI. I will try craft when i don’t get any answer for win build. It should be actually global problem when doing with guide which link i posted as well


#4

ping! anyone. can you help?


#5

Got solved with git submodule update --init --recursive