Win client shows new files as synced, but they aren't

help

#1

The Owncloud version on the NAS - a QNAP TS-459 Pro II running QTS 4.2.2 - is ownCloud 8.0.4 (stable). I downloaded it from QNAP's appcenter (as I don't know enough Linux to do an installation from the command line).
Owncloud version on the laptop (which runs Win7) is Version 2.2.2 (build 6192).

Yesterday I added a few new files to the directory that oc syncs while Windows 10 was running (I have Win7 and 10 running in 2 separate partitions of my SSD). Then I booted into Win 7 again. There, oc showed all the new files as synced (green checkmarks shown in the windows explorer).

The directory that oc observes is on a harddisk that has the same drive letter in Win7 and Win10 (not on that partitioned SSD).

When I opened oc on the QNAP, the new files were not there.

Expected behaviour
Files added to the directory under Windows should by synced into the NAS.

Actual behaviour
New files don't show up on the NAS

Client configuration
Client version: 2.2.2 (build 6192).
Client operating system: Windows 7 Professional 64 bit

Server configuration
Operating system: QNAP QTS 4.2.3 (2017/01/21)
Web server: don't know - where / how can I look this up?
Database: don't know - where / how can I look this up?
PHP version: don't know - where / how can I look this up?
ownCloud version (see ownCloud admin page): ownCloud 8.0.4 (stable)
Updated from an older ownCloud or fresh install: don't remember
Special configurations (external storage, external authentication, reverse proxy, server-side-encryption): not that I know

I also found a log file on the server side, but it was too big to enter here - when I tried, I could not create the post. Is there no way to attach a file? It is 392 kB in size.


#2

Hi,

ownCloud 8.0.4 is outdated (8.0.16 was the latest release of this branch so you're missing 12 updates). Furthermore the 8.0.x branch is end-of-life and unsupported since the end of the last year.

Finally its strongly discouraged to run ownCloud on a QNAP device for the reason explained in [1] and [2]. QNAP is not capable to provide a recent version of a system library (libxml 2.7.0 released around 8 years ago) which is needed for running ownCloud.

You might want to contact the QNAP support about this issue. If more QNAP users are stepping up and nagging their support then they might change their minds and provide recent and up2date software versions.

[1]

[2]


#3

This really surprized me - my installation worked pretty well for the last few years.

Looking around I found this - looks as if somebody already prepared a newer version for qnap.

Unfortunately I could not find the required Qapache - the files offered in QNAP Club are all 0 length. I wrote to Stephane, hopefully he will reply soon and provide a suitable package.


#4

This libxml requirement is there since longer time and will show issues if you're using e.g. the Desktop Client of ownCloud. See the following thread if you want to get some more background info:


#5

Unfortunately, Stephane did not answer.

Anyway, in the meantime I moved all my data on to a new NAS, the TS-251+, because I got close to running out of disk space on the old one, and I wanted to use one that consumes less power. The TS-251+ also runs QTS 4.2.3. I installed ownCloud 8.0.4 from the QNAP App Store, redirected my Windows client to it, and it works!

I will come back here if I should run into problems again. In the moment I see no reason to change anything. Never touch a working system...

Thank you for your support!


#6

I hope you are only using this in your local network (even then it would be better to upgrade). The new QNAP doesn't provide a newer libxml version that allows you to use more recent versions of ownCloud?


#7

Yes, I'm using it only in my local network. I hope to be able to access it from outside of it one day in the future, but with my present internet connection (upload speed max. 1 Mb/s) I don't even want to try. Hopefully I will get FTTH this year, this should allow decent upload speeds.