"You don’t have permission to upload or create files here”

Hello, recently installed OwnCloud 10.9.1 (I am running in Hyper-V). All appears to be running correct, I am able to upload file from my smartphone etc…
So far I have managed to do the following:

  • Mount a Windows Share (on my local network) to /media/FamilyBackup

and when I go into OwnClound Admin under external I am able to mount this same folder to appear in as an External Folder in my list of folders under All Files. I can go into it and even see the files that are on the Windows Machine that are in it. For some reason even after following some other threads here I am unable to upload to it as it keeps a “You do not have permission to upload or create files here” at the top of that folder when viewing.
I have used CHOWN -777 on the folder, I have tried everything, so instead I tried option B which is actually my preferred option.

This is to just mount the windows share as an SMB Personal (Unique file IDs) in the “External Storage” options under ADMIN in OwnCloud.
I enter the fields correctly (the Green circle appears on the left), and my windows security log shows the LOGIN. However then it immediately shows a LOGOUT. When I go to the files list in OwnCloud it lists the SMBPERSONAL folder but when I click it, it “tries” then goes right back to the main list of files again. I even enabled SMB1 in my Windows Environment and still no avail.

Help? I am SO CLOSE!

If it’s a fresh install, better use the latest version.

For the issue itself, it’s highly recommended to install the php-libsmbclient library (GitHub - eduardok/libsmbclient-php: smbclient's extension for PHP). You might want to check first if there are packages available for your distribution.
Make sure it’s installed and ready to be used by apache or whatever web server you’re using. You might need to restart the server.

If that doesn’t solve your problem, we’ll need logs to know what’s happening. You might also want to add some screenshots of the external storage settings. Of course, hide any critical / confidential info.


The version 10.9 might be due to the fact that they are potentially using the appliance.

@Fordzilla Please fill out the post template, that way we can understand your environment much better.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.