You need to set your user email before being able to send test emails

smtp
9.1.x

#1

Hi,
I am getting "You need to set your user email before being able to send test emails." when I send a Test email using send mode smpt or php.

I checked my smpt configuration and it is all fine.

Version

ownCloud 9.1.5 (stable)

config.php
'dbuser' => 'oc_ocadmin',
'dbpassword' => 'Nrwsor1vcjdib10qfPSK5FaF2SQrzO',
'logtimezone' => 'Europe/Ljubljana',
'installed' => true,
'instanceid' => 'oc8sd4oseysj',
'appstore.experimental.enabled' => 'true',
'mail_smtpmode' => 'smtp',
'mail_smtpport' => '587',
'mail_smtphost' => 'smtp.ztm.si',
'mail_from_address' => 'sit',
'mail_domain' => 'ztm.si',
'mail_smtpsecure' => 'tls',
'preview_libreoffice_path' => '/usr/bin/libreoffice',
'memcache.local' => '\OC\Memcache\Redis',
'filelocking.enabled' => true,
'memcache.distributed' => '\OC\Memcache\Redis',
'memcache.locking' => '\OC\Memcache\Redis',
'redis' =>
array (
'host' => '/var/run/redis/redis.sock',
'port' => 0,
'timeout' => 0,
'dbindex' => 0,
19,3 56%


#2

This sounds to me more that you don't have added your own e-mail address in the personal area of your ownCloud.