Your Data directory is readable by other users

Hi Everyone

I would like to start off by saying I am relativity new to Owncloud and Linux so you may have to be patient with me sorry.

I have installed Owncloud on openmediavault on a raspberry pi with an external ntfs hdd which has been a task in itself.

Anyway I have got to the point where i have setup the admin user and the database on owncloudbut I cant go any further because ive got this error
Your Data directory is readable by other users
Please change the permissions to 0770 so that the directory cannot be listed by other users.

I understand there are some issues getting permissions working with ntfs but i have successfully executed these commands in ssh to try and solve the problem but no joy

sudo chown -R www-data:www-data /srv/dev-disk-by-id-ata-ST1000LM035-1RK172_WC00DQ7X-part1/www/owncloud/data


chmod -R 0770 /srv/dev-disk-by-id-ata-ST1000LM035-1RK172_WC00DQ7X-part1/www/owncloud/data

Please can anyone help me I would be so grateful




Can you show your config.php?

Hi Thanks for your response the output is

GNU nano 2.2.6 File: config.php
[New File]

I don't think that you can apply linux permissions on a windows filesystem. You probably need to find another way to set the correct permissions.

1 Like

I know i think there is a way using ntfs 3g but i dont know how to set that up

NTFS does not support Linux file permissions and ownCloud server does not support NTFS as primary storage. Please use a Linux file system.

Maybe it could be a good idea to add this to the documentation.

Ok I have backed up and erased data on the drive and tried to re-add the drive as ext4 but I cannot do so as i get this error when trying to mount the disk

Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; mount -v --source '/dev/sda1' 2>&1' with exit code '1': mount: can't find mount source /dev/sda1 in /etc/fstab

Any ideas?

Well, the docs say that implicitly. Only Linux is supported as a server operating system ( As you can't install Linux on a NTFS partition you can't use ownCloud with it either. In the end it does not make sense to list all "supported/unsupported" file systems in the docs. You can only use ownCloud Server on Linux so you can only use the file systems that Linux runs on as a primary storage (apart from storages you connect via S3 but that's another story).

You have to format the disk/partition with a Linux file system like ext4 and mount it. Can't help much on this with the information provided. There's lots of resources out there on formatting and mounting so just give your favorite search engine a try.

Well, if it would be such obvious you wouldn't see so many posts about NTFS similar to this (see e.g. :wink:

In general i'm not really convinced by your arguments, e.g. the OP is still using Linux as the server operating system and just only moved the data directory on a NTFS partition (which is supported mostly natively by linux). Adding to this there is the external storage app with the "local storage" option bringing even more complexity into this.

Right I have formatted the disk it works fine now thankyou. Next issue I had over 200 GB of data on the drive i backed up I want to put it back in my ownclouds user folder where is this located?

What user ? the admin or does this user has a name?

In your config.php you have set a home directory, for example /data

in that case you would have to go to the /data folder and look for the user there, for example "admin" and put the data in the "admin" folder.

I am getting this message while trying to open owncloud on my QNAP NAS. Has anyone got this issue, any help would be great.

Your Data directory is readable by other users
Please change the permissions to 0770 so that the directory cannot be listed by other users.

1 Like

I am getting the same issue after update the ownCloudX with the new version recommended by the App Center. Did you contact Qnap? I contacted them, but no reply yet.

I don’t have a QNAP so I can’t try it myself, but have you considered going into the folder settings and changing the permissions? I think this should be available through the web interface via a right click. Otherwise you will have to figure out how to log in via SSH and set the permissions with chmod.

1 Like

Did you find a solution to this issue?
I have tried uninstalling the app from my QNAP and re-installed again. Now I don’t get that message. However, I am still not sure how to connect NAS to owncloud. I have tried using SFTP, I think i miss something. If you have something to share, that would be great.

Have you tried adjusting the permissions? Just remove rwx for others like so:

chmod o-rwx -R folder
1 Like

Hi, I think that i resolve it another time… but I can’t to resolve again… I’m remove data folder and use simboliclink, to drive NTFS mounted in /media/user/drive/owncloud, I resolve some errors messages… but I have this error

Please change the permissions to 0770 so that the directory cannot be listed by other users.


from what i have read in the past in the post below ownCloud doesn’t support NTFS formatted file systems: