ZIP-file can´t be opened after "download all" from OC 10


I tried downloading shared files in a folder via the "download all"-option. The generated ZIP-file was downloaded, but it was not the expected 3,5 GB, but about 1,7 GB. Also, the ZIP-file can not be opened (not via 7-zip, or Windows Explorer). I tried it 4 times, the outcome was always the same. The files comprise of pictures and videos.

Can someone tell me, how to solve this problem?

Owncloud used: 10.0.3 (stable)

My system used: Win 10, Firefox, 200MB downstream-connection, Windows Explorer, 7-zip


Try to edit this file: /etc/php/7.0/apache2/php.ini

and there adjust this value

max_execution_time = 30

to something bigger, like 60 or 120 and check if you can download the large file.

max_execution_time is 240 seconds
memory limit is 1024
php 7.1

Okay, does the error still occur?

You can apparently just write 6000 :smiley:

The error occured, while it was at 240 seconds. Never changed anything. Don´t ypou think it should work with 240? I mean 6000? I bit hight, right? :smiley:

I searched the doc, and found this:

the value is 3600, so not so far away from 6000

The highest option I can enter is 2400 seconds, sadly (it´s a managed server). I did this, but I got the same result. If I use the "download" option of a shared folder, ca. half of its filesize is downloaded (1,7 to 1,9 GB instead of 3,5GB) and the ZIP-file cant be opend or read.

It the same, by the way, if I mark every file via the checkboxes and then use the "download"-option to the right, above the filesize column.

And: A big THANK YOU for you help so for and fpr trying!

Thats unfortunate. I had a similar issue. Wanted to download a whole season of a TV-show, and the download kept dying at 1.5 -1.7 GB of the originally 8 or 9. I keep on looking for a solution

Noone else has any idea?

I am back...with suggestions :slight_smile:

Increase this values and try to download the file:

session.gc_maxlifetime to 6000 or the max value that you can

upload_max_filesize to 16G

post_max_size to 16G

memory_limit = 1G

max_input_time = 6000