423 locked file when trying to update


#1

Client = windows 10 64bit, running 2.4.0 owncloud client.
Server = Cent OS 7 running owncloud 10.4.0 server

When I deleted a file in the sync directory, it is throwing an error on the client:

2/3/2018 9:24:58 PM,tools-keys-etc/software/CISCO VPN/vpnclient-winx64-msi-5.0.07.0290-k9.exe,E:\DUDES\backups-resume-drivers,Server replied "423 Locked" to "DELETE https://chi.swamp.xyz/owncloud/remote.php/dav/files/vivithemage/backups-resume-drivers/tools-keys-etc/software/CISCO VPN/vpnclient-winx64-msi-5.0.07.0290-k9.exe"

Everything else is going fine. I also noticed though, that I deleted a directory on the client, and it would not sync, also threw an error, but I ignored it, and just removed it from syncing in the interface.

I do have encryption on the server enabled, for whatever that's worth. I also have been using this instance since 7.x I think, before the merger, and beyond, haha. It's worked great up to this point.


#2

Hi,

do you have file locking enabled?


#3

Where can I see that?


#4

In your config.php. But if you ask I assume that you don't.

you could clear this table in your database, this deletes all the locks on your files:

oc_file_locks

here is the command to use:

truncate oc_file_locks


#5

I don't think that was it:

MariaDB [clouddb]> truncate oc_file_locks;
Query OK, 0 rows affected (0.01 sec)

I did confirm I do not have oc_file_locks in my config file.


Update 10.0.3.3 to 10.0.6 stuck
#6

Ah, I resolved it. Looks like my cron jobs may have never ran. So I ran it manually.

I dumped myself into the apache user:

su -s /bin/bash apache

then ran the cron job script, which took about 30 minutes or so.

php -f /var/www/html/owncloud/cron.php

I then added it to crontab for apache:

crontab -e -u apache
*/15 * * * * php -f /var/www/html/owncloud/cron.php