Access forbidden by server on windows desktop client Application


#1

Hi Everyone I am totally new to own cloud. Please help me solve this problem by step by step method because i am not a tech geek. And also sorry for bad English.

Expected behavior

Tell us what should happen

Actual behavior

I have enable TOTP on my own cloud users account after this all desktop sync client was not connected with my server. if i disable TOTP then it;s working fine. i am accessing my server with HTTP conncetion What is the problem.
i am using OC 10.0.3 on Ubuntu 16.04LTS with LAMP on google instance.

Steps to reproduce

Server configuration

Operating system: Ubuntu 16.04LTS

Web server: APACHE

Database:MYSQL

PHP version:7.0

ownCloud version:10.03

Storage backend (external storage):

Client configuration

Client version:OC WINDOWS DESKTOP SYNC 2.3.3.8250

Operating system:WINDOWS 8.1 PRO

OS language:ENGLISH

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client:

Logs

Please use Gist (https://gist.github.com/) or a similar code paster for longer
logs.

Template for output < 10 lines

  1. Client logfile: Output of owncloud --logwindow or owncloud --logfile log.txt
    (On Windows using cmd.exe, you might need to first cd into the ownCloud directory)
    (See also http://doc.owncloud.org/desktop/2.2/troubleshooting.html#client-logfile )

  2. Web server error log:

  3. Server logfile: ownCloud log (data/owncloud.log):


#2

Hi,

What is totp and how did you enable it?


#3

Hi dmitry

this OTP app from OC market. i Installed from market then i enable using google authenticator
after that this desktop client application won't connect with my server.


#4

Two Factor TOTP Provider

Do you mean this app?


#5

Yes Dimitry..Yes i have installed from OC market...


#6

AFAIK, there is no two-factor provider auth implementation in client side. Because of that, If you enable a second factor, server doesn't accept regular login/password, only accepts token. So, it is expected behavior. You should generate app password to authorize clients.


Two Factor Authentication
#7

Correct. With the upcoming 2.4.0 desktop client and the new oAuth2 app on the server it will be possible to use a new flow, but till then this is the reason.


#8

Thank karakayasemi.
But How i generate app passwords and how to give password in client app..?


#9


#10

Hi karakayasemi
Thanks for your information but where to give application password in sync application.
Sry for the basic qus... bcz i am totally new to IT field.


#11

You should generate app password from web application personal settings interface and use the password in the client authentication.