After update to 9.1.2 some files have a yellow exclamation mark

9.1.x
help

#1

Hello there,

after an update to 9.1.2, I have on some files yellow exclamation marks.
The files are not synced with the server, I checked with login by http.
Before updating from a 7.xx Owncloud, all files were synced perfektly (including the ones, that have the exclamation mark now).

What I have done: I have updated Owncloud form a old 7.x to the newest 9.1.2.
To have a clean update, I deleted all old owncloud files including config and data and the whole MySQL database.
Then I uploadet the new files and did the installation procedure.
So far, all worked well.
After syncing my personal data (pictures, documents, movies, etc.) with Windows desktop client 2.2.4 (build 6408) on Windows 10, some files have these yellow mark.
Some are .jpg, some are .pdf, some are others.
All the unsynced files have a red x

The logfile at the non synced files tell me, that some files are locked - but I never lock files (how can I do this?).
Here you can see the log file:

22.11.2016 15:22:47, Datenaustausch/WJ Jubiläumsball/IMG1758.jpg, D:\ownCloud,Error downloading http://www.hennpro-luftbild.de/owncloud/remote.php/webdav/Datenaustausch/WJ Jubiläumsball/IMG_1758.jpg - server replied: Locked ("Datenaustausch/WJ Jubiläumsball/IMG_1758.jpg" is locked)_
_ 22.11.2016 15:22:45,Projekte/HennPro Modelltechnik/Lexware/HennPro Modelltechnik_150520_174836.qbs, D:\ownCloud,Error downloading http://www.hennpro-luftbild.de/owncloud/remote.php/webdav/Projekte/HennPro Modelltechnik/Lexware/HennPro Modelltechnik_150520_174836.qbs - server replied: Locked ("Projekte/HennPro Modelltechnik/Lexware/HennPro Modelltechnik_150520_174836.qbs" is locked)_

There are way more unsynced files, who are not listed in the log file in the client.
I don't know why.

Owncloud 9.1.2 is running on Apache with PHP 5.6 and MySQL 5.6.

Can you give me some advice, what can I do?
Regards


#2

There is a FAQ available here explaining all known infos about this "file is locked" message:


#3

Thank you for the link.
I deleted the specified SQL entry. but the problem is still there.
Then I added 'filelocking.enabled' => false, in config.php and the problem is still there.

Do you have another idea to solve this?


#4

Hi,

all known infos are collected there. If there would be additional ideas / infos it would have been added to that FAQ.


#5

I solved the problem!

I switched to PHP 7.0 and switched on SSL.
So I think it was not the switch to SSL, I think change to PHP 7.0 was the key.


#6

I had the same kind of errors after an update from 9.1.2 to 9.1.3 on CentOS 7.

The FAQ "File is locked - how to unlock" was not helpful. Redis was already enabled as a locking mechanism.

I finally found this thread and following Galumbo idea: I switched form PHP 5.4.6 to PHP 7.0 and the problem was solved (SSL was already enabled).