After upgrade: the server does not support WebDAV


#1

Hi there.

We have been using owncloud for several years now.

Since Monday we use webDAV via davfs2 and since yesterday it does not work any more.

Our System is Ubuntu 16.04.3 LTS, i did install owncloud from the repo
deb http://download.owncloud.org/download/repositories/production/Ubuntu_16.04/ /

I did mount webDAV folder with following entry in .davfs2/secrets:
https://myhostname/remote.php/dav/files/username/ username password
and
mount /my/path/to/folder/like/in/fstab
what did work like a charme.

Yesterday the server told me to upgrade (nothing special...). I did start the upgrade and averything worked fine.

Only the mount of the folder does not work anymore, it stops with the note
"/sbin/mount.davfs: mounting failed; the server does not support WebDAV"

The URL remote.php/webdav/ works neither.

The DesktopClient works as usual.
The Scanner, using webDAV, works as usual.
The WebFrontEnd works as usual.

Version the server upgraded to is ownCloud 10.0.4 (stable) , exactly 10.0.4.4

Any hints? Thanks in advance.


#2

I think this looks like exactly the same as some one else report: https://central.owncloud.org/t/owncloud-10-0-4-4-davfs-issue/10741


#3

Yes, issue is worked on: https://github.com/owncloud/core/issues/29793


#4

Hi!
Thank you very much for your replies.

Following hodyroff's link I got https://github.com/owncloud/core/pull/29798
I did edit the apps/dav/lib/Connector/Sabre/CorsPlugin.php manually as described there and it works fine.

I have to apologize for not having found the solution by myself, but google didn't show me.


#5

No problem, thanks for letting us know its solved.